This is a migrated thread and some comments may be shown as answers.

Always use Appointment edit dialog

3 Answers 60 Views
Scheduler and Reminder
This is a migrated thread and some comments may be shown as answers.
AMF
Top achievements
Rank 2
AMF asked on 15 Jun 2011, 02:16 PM
Is there an option in the RadScheduler to force the user to use the edit dialog?

Default the user is able to type the appointments directly in the scheduler. In this case the only field that is being used is the Subject.
I created a custom edit dialog, and added a few fields. These fields are mandatory, and to fill this fields the user needs to use the edit dialog.

So is this possible?

3 Answers, 1 is accepted

Sort by
0
Accepted
Ivan Todorov
Telerik team
answered on 20 Jun 2011, 03:24 PM
Hi AMF Microsign,

Thank you for your question.

This has already been requested by other users and we will consider adding a property to prevent appointments from being created inline in the next official release. For the time being, you can use the following workaround:

public Form1()
{
    InitializeComponent();
    radScheduler1.SchedulerElement.EditorManager = new MySchedulerEditManager(radScheduler1.SchedulerElement);
}
  
class MySchedulerEditManager : SchedulerEditManager
{
    public MySchedulerEditManager(RadSchedulerElement element): base(element)
    {
          
    }
  
    public override bool BeginInlineEdit()
    {
        this.SchedulerElement.View.UpdateAppointments(this.SchedulerElement.Scheduler.Appointments);
        return false;
    }
}

Hope this helps. Do not hesitate to contact me back if you have any additional questions.

Greetings,
Ivan Todorov
the Telerik team
Q1’11 SP1 of RadControls for WinForms is available for download; also available is the Q2'11 Roadmap for Telerik Windows Forms controls.
0
Vijay
Top achievements
Rank 1
answered on 30 Oct 2013, 04:30 PM
I want to disable Inline Editing as well and used the code you had provided. Before implementing the code I could create type what I want and it would create the appointment using Inline Edit.

After using the code, the behaviour has changed so that it would let me enter in the first letter only and STILL create the appointment.

Any help would be appreciated.

Thanks,
Vijay
0
Dess | Tech Support Engineer, Principal
Telerik team
answered on 04 Nov 2013, 02:34 PM
Hello Vijay,

Thank you for contacting Telerik Support.

In order to disable inline editing, you may use AllowAppointmentCreateInline property:
radScheduler1.AllowAppointmentCreateInline = false;

The provided code in the previous post is a workaround for preventing inline editing for versions until Q1 2011 SP1 includingly.

I hope this information helps. Should you have further questions, I would be glad to help.

Regards,
Desislava
Telerik
TRY TELERIK'S NEWEST PRODUCT - EQATEC APPLICATION ANALYTICS for WINFORMS.
Learn what features your users use (or don't use) in your application. Know your audience. Target it better. Develop wisely.
Sign up for Free application insights >>
Tags
Scheduler and Reminder
Asked by
AMF
Top achievements
Rank 2
Answers by
Ivan Todorov
Telerik team
Vijay
Top achievements
Rank 1
Dess | Tech Support Engineer, Principal
Telerik team
Share this question
or