'Build and Deploy' to Android device suddenly fails

Thread is closed for posting
3 posts, 0 answers
  1. MoriartyX64
    MoriartyX64 avatar
    19 posts
    Member since:
    Jun 2013

    Posted 14 Aug 2014 Link to this post

    Suddenly, as of today, I am unable to 'Build and Deploy' to my Android device. I'm using the AppBuilder Visual Studio extension, version 2014.2.806.3. This worked perfectly earlier this week, up until last tuesday, but now I'm constantly getting errors on Android only.

    Some facts:

    * No mentionable changes (like project properties, plugins and such), except for changes in the html
    * Simulator works fine
    * Only fails on Android; Deployment to iPhones works perfectly
    * Deployment worked before (tuesday was last succesful deploy to the Android)
    * Build and Deploy in cloud fails as well (error: "Cannot find application package for Android. See the log for more information.")
    * Device is found in the devices list

    I have already tried the following, without success:

    * Restarted Visual Studio and the system
    * Rebooted the Android device + killed all running applications
    * Reconnected the device, building in the cloud, build and publish locally
    * Clearing the cache: %localappdata%\Telerik\BlackDragon\Cache

    Build output: 

    Building package: [C:\Work\SRC\<bla bla bla>.zip]
    Project files uploaded to the cloud.
    Sending build request for project <bla> with parameters ProjectTypeGuids={<bla bla bla>}
    LiveSyncToken=<bla bla bla>.
    Package is successfully built. Result is at Android.
    Downloading from bin\Android\Debug\bin\<bla>.apk to C:\Work\SRC\<bla bla bla>.apk.
    File downloaded successfully at C:\Work\SRC\<bla bla bla>.apk.
    Build on cloud finished.

    AppBuilder output:

    [2014-08-14 13:14:45.978] Log (Info,Medium): The Windows Phone SDK is not installed on this system. To build and deploy Windows Phone applications on devices, install the Windows Phone SDK.
    [2014-08-14 13:14:46.337] Log (Info,Medium): AppBuilder for Visual Studio version 2014.2.806.3. AppBuilder server location https://app.icenium.com.
    [2014-08-14 13:14:55.178] Log (Info,Medium): Update check completed. The extension is up-to-date. Authenticating with Telerik Platform...
    [2014-08-14 13:14:57.939] Log (Info,Medium): The user '<my name>' logged in to Telerik Platform.
    [2014-08-14 13:15:28.237] Log (Info,Low): Found device GT-I9505
    Failed to deploy application <bla bla bla> to GT-I9505: Application '<bla bla bla>' not found on device 'GT-I9505'..
    [2014-08-14 13:20:15.529] Log (Exception,High): Telerik.BlackDragon.Client.Mobile.MadBee.Exceptions.PackageInstallationException: INSTALL_FAILED_UID_CHANGED
       at Telerik.BlackDragon.Client.Mobile.MadBee.Device.InstallRemotePackage(String remoteFilePath, Boolean reinstall)
       at Telerik.BlackDragon.Client.Mobile.MadBee.Device.InstallPackage(String packageFilePath, Boolean reinstall)
       at Telerik.BlackDragon.Client.Mobile.Android.AndroidDevice.<>c__DisplayClass1c.<DeployPackageAsync>b__1a()
       at System.Threading.Tasks.Task.InnerInvoke()
       at System.Threading.Tasks.Task.Execute()

    Any suggestions are more than welcome...
  2. MoriartyX64
    MoriartyX64 avatar
    19 posts
    Member since:
    Jun 2013

    Posted 14 Aug 2014 in reply to MoriartyX64 Link to this post

    Update: I have absolutely no idea what caused this suddenly. But it appears I'm not the only one with this issue, see also:

    There seem to be three possible fixes for this:

    1. Change the application name, e.g. identifier. This was no option for me.
    2. If you have root access to the Android device you can try to find some remaining clutter that blocks a deploy. 
    3. Reset the device (to factory settings)

    The last option worked and therefor the issue is resolved for me. Hope this helps other as well.
  3. Kaloyan
    Kaloyan avatar
    880 posts

    Posted 19 Aug 2014 Link to this post

    Hello MoriartyX64,

    Thank you for contacting us about this issue. It appears to be a common matter for Android applications, as from the link you have provided. I am glad you have found a solution that works for you.

    Further, you can also check if uninstalling the app manually from the device and deleting all its data folders solves the issue. This is explained in more details here.

    As a token of gratitude for sharing the solution with our community, I have updated your Telerik points. Please, let us know if there is anything else, we can help you with.


    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

Back to Top