WPF desktop application is getting auto closed when record the script from visual studio 2013

2 posts, 0 answers
  1. Yogendra
    Yogendra avatar
    1 posts
    Member since:
    Aug 2018

    Posted 09 Aug 2018 Link to this post

    Hi,

    I have Configured WPF application path then record the script.

    The application is getting auto closed on the splash screen when recording the script from visual studio 2013.

    Also, when I use other WPF application. It only detects touch points by x, y position. Not able to find and click on elements.

  2. Elena
    Admin
    Elena avatar
    1104 posts

    Posted 14 Aug 2018 Link to this post

    Hello Yogendra,

    Thank you for reaching us out. 

    Can you please elaborate more on the issue you experience - do you see the recorder toolbar attached to the WPF application? Or only the splash screen appears and the recording process does not proceed? 

    When saying no elements are detected in any WPF app do you mean you could not highlight any element and locate it in the DOM tree? If you could record a short video it will be useful to better understand what might be failing. 

    You also mentioned the misbehavior can be observed when using Test Studio plugin in VS 2013 - have you tried to start the standalone application? Which is the version of Test Studio you are using? 

    Also you could try attaching the recorder to an already running application - please see the attached screenshot for reference. 

    Please let me know the above details to be able to continue the investigation. Thanks in advance! 

    Regards,
    Elena Tsvetkova
    Progress Telerik
     
    Quickly become an expert in Test Studio, check out our new training sessions!
    Test Studio Trainings
     
Back to Top