Wikitude plugin just disappeared

9 posts, 0 answers
  1. Pablo
    Pablo avatar
    32 posts
    Member since:
    Feb 2015

    Posted 12 Jan Link to this post

    Wikitude plugin just disappeared, I cant find it, so I cant build the app because the plugin just disappeared.
    What happened, what can I do, where can I find it.

    HELP

  2. Tsvetina
    Admin
    Tsvetina avatar
    2085 posts

    Posted 16 Jan Link to this post

    Hello Pablo,

    This article explains that the plugin was removed from the Verified Plugins Marketplace and how to add it to your app now:
    How to Import Wikitude Plugin in Telerik Platform App

    Regards,
    Tsvetina
    Telerik by Progress
     

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

     
  3. Pablo
    Pablo avatar
    5 posts
    Member since:
    Jan 2015

    Posted 31 Jan in reply to Tsvetina Link to this post

    Tsvetina, we have a biog problem here, please give me an option.

    I followed the instructiosn, but afetr trying to understabnnd what is going on, I noticed the plugin file is bigger that your 50Mb limit, so now I cant iport it and I can use the Marketplace.

    I hate when a company like Telerik does those things to their followers.

    Please, please give us an option, there is some of us using this plugin.

     

     

  4. Pablo
    Pablo avatar
    5 posts
    Member since:
    Jan 2015

    Posted 31 Jan in reply to Pablo Link to this post

    Tried with CLI, no luck, is there a way?

    "appbuilder plugin fetch https://github.com/Wikitude/wikitude-cordova-plugin/archive/master.zip"

     

    [...................] \ : WARN Building the local index for the first time, please be patient
    <--- Last few GCs --->

      113124 ms: Mark-sweep 1117.1 (1433.8) -> 1111.3 (1437.8) MB, 940.3 / 0.0 ms [allocation failure] [GC in old space requested].
      114224 ms: Mark-sweep 1111.3 (1437.8) -> 1111.2 (1437.8) MB, 1100.2 / 0.0 ms [allocation failure] [GC in old space requested].
      115253 ms: Mark-sweep 1111.2 (1437.8) -> 1119.1 (1406.8) MB, 1028.7 / 0.0 ms [last resort gc].
      116275 ms: Mark-sweep 1119.1 (1406.8) -> 1127.0 (1406.8) MB, 1022.1 / 0.0 ms [last resort gc].


    <--- JS stacktrace --->

    ==== JS stack trace =========================================

    Security context: 0000026D079CFB61 <JS Object>
        1: /* anonymous */ [C:\Users\pablo\AppData\Roaming\npm\node_modules\npm\lib\cache\update-index.js:90] [pc=0000022E1D43DC6F] (this=0000026D079E6659 <JS Global Object>,er=0000026D07904201 <null>,upda
    tes=000002413D104201 <an Object with map 000000977EF80641>,_=0000029503004201 <Very long string[237012792]>,res=0000031C0EFFFE81 <an IncomingMessage with map 000000977EFD8F89>)
        2: /* anonymo...

    FATAL ERROR: CALL_AND_RETRY_LAST Allocation failed - JavaScript heap out of memory
    .
    Command npm.cmd failed with exit code 3

  5. Pablo
    Pablo avatar
    5 posts
    Member since:
    Jan 2015

    Posted 31 Jan in reply to Pablo Link to this post

    Sorry, I used this command:

    appbuilder plugin fetch C:\wikitude-cordova-plugin-master.zip

  6. Pablo
    Pablo avatar
    5 posts
    Member since:
    Jan 2015

    Posted 31 Jan in reply to Pablo Link to this post

    Sorry used this command:
    appbuilder plugin fetch C:\wikitude-cordova-plugin-master.zip
  7. Garo
    Admin
    Garo avatar
    136 posts

    Posted 03 Feb Link to this post

    Hello Pablo,

    When you are using the AppBuilder CLI, you can directly extract the content of the ZIP file to the Plugins folder of your project. This way you will gain access to the plugin.

    Additionally, the error message that you are receiving is a known issue for NPM 3. To resolve this you have to update to NPM 4. However, due to the fact that the plugin does not contain a package.json file you cannot use the appbuilder fetch command to add it to your project.

    Please, let me know if extracting the content of the ZIP to the plugins folder resolved the issue and you can use the plugin successfully.

    Regards,
    Garo
    Telerik by Progress
     

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

     
  8. Pablo
    Pablo avatar
    5 posts
    Member since:
    Jan 2015

    Posted 08 Feb in reply to Garo Link to this post

    Did everything you recomended.

    Can't Build. This has become a nigthmare, please, what should I do?

     

    [2017-02-08 09:22:21.895] Log (Info,None): Project "***.tmp.proj" (default targets):
    Warning: Cannot include the following item(s) in your application: bower_components\angular-animate\.bower.json;bower_components\angular-audio\.bower.json;bower_components\angular-audio\.editorconfig;bower_components\angular-audio\.gitattributes;bower_components\angular-audio\.gitignore;bower_components\angular-audio\.jshintrc;bower_components\angular-audio\app\.htaccess;bower_components\angular-audio\test\.bowerrc;bower_components\angular-leaflet-directive\.bower.json;bower_components\angular-leaflet\.bower.json;bower_components\angular-media-player\.bower.json;bower_components\angular-media-player\.bowerrc;bower_components\angular-media-player\.editorconfig;bower_components\angular-media-player\.gitignore;bower_components\angular-media-player\.jshintrc;bower_components\angular-media-player\.travis.yml;bower_components\angular-messages\.bower.json;bower_components\angular-sanitize\.bower.json;bower_components\angular-simple-logger\.bower.json;bower_components\angular-translate\.bower.json;bower_components\angular-ui-router\.bower.json;bower_components\angularfire\.bower.json;bower_components\AngularJS-Toaster\.bower.json;bower_components\angular\.bower.json;bower_components\firebase\.bower.json;bower_components\ion-gallery\.bower.json;bower_components\ion-md-input\.bower.json;bower_components\ionic-material\.bower.json;bower_components\ionic-material\.cz.json;bower_components\ionic-material\.gitignore;bower_components\ionic-material\.jshintrc;bower_components\ionicitude\.bower.json;bower_components\ionic\.bower.json;bower_components\leaflet-dist\.bower.json;bower_components\leaflet\.bower.json;bower_components\ngCordova\.bower.json;bower_components\waves\.bower.json;Plugins\cordova-plugin-firebase-messaging-master\.gitignore;Plugins\wikitude-cordova-plugin-master\.gitignore. The build system treats items with a leading dot as hidden files or directories and does not process them. If you want to include these items in your application package, rename them and rebuild your app.
    android Build Tooling revision 2017.01.26.3r
    Build Tooling Hostname 91f776f29c54
    Warning: Running hook to copy any available google-services file to Android
    Warning: fileExists error: Error: ENOENT: no such file or directory, stat 'google-services.json'
    Warning: fileExists error: Error: ENOENT: no such file or directory, stat '/tmp/builds/C3xKo1lVL4nzndRov8/app/assets/www/google-services.json'
    Warning: Note: Some input files use or override a deprecated API.
    Warning: Note: Recompile with -Xlint:deprecation for details.
    Warning: Note: Some input files use or override a deprecated API.
    Warning: Note: Recompile with -Xlint:deprecation for details.
    Warning: /tmp/builds/C3xKo1lVL4nzndRov8/app/AndroidManifest.xml:38:5-74 Error:
    uses-sdk:minSdkVersion 14 cannot be smaller than version 15 declared in library [:wikitudesdk:] /tmp/builds/C3xKo1lVL4nzndRov8/app/build/intermediates/exploded-aar/wikitudesdk/AndroidManifest.xml
    Suggestion: use tools:overrideLibrary="com.wikitude.architectandlib" to force usage
    Warning: FAILURE: Build failed with an exception.
    Warning: * What went wrong:
    Warning: Execution failed for task ':processArmv7DebugManifest'.
    Warning: > Manifest merger failed : uses-sdk:minSdkVersion 14 cannot be smaller than version 15 declared in library [:wikitudesdk:] /tmp/builds/C3xKo1lVL4nzndRov8/app/build/intermediates/exploded-aar/wikitudesdk/AndroidManifest.xml
      Suggestion: use tools:overrideLibrary="com.wikitude.architectandlib" to force usage

    * Try:
    Warning: Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
    Warning: undefined
    Error: Build failed during execution
    Error: 'Build failed with error code 2'
    Done building project "***.tmp.proj" -- FAILED.

    [2017-02-08 09:22:21.905] Log (Exception,High): Build and Deploy: 'Unable to build and deploy *** on one or more devices. For more information, see the log.' on 8/2/2017 9:22:21

  9. Garo
    Admin
    Garo avatar
    136 posts

    Posted 09 Feb Link to this post

    Hello Pablo,

    When testing on a newly created project with only the Wikitude plugin included, I was able to reproduce only this error: "uses-sdk:minSdkVersion 14 cannot be smaller than version 15 declared in library [:wikitudesdk:]". To resolve it, please follow these steps:
    1. Open your app.
    2. Right-click on your app name and select Edit Configuration > Android Manifest.
    3. Scroll to the bottom of the file and make the follow change:
      // From
      <uses-sdk android:minSdkVersion="14" android:targetSdkVersion="21"/>
      // To
      <uses-sdk android:minSdkVersion="15" android:targetSdkVersion="21"/>

    I am not sure if the missing file will cause the build to fail after you have implemented the fix suggested above. However, I do not believe that this is connected to the Wikitude plugin and I will need to see your project to determine what is causing it.

    Regards,
    Garo
    Telerik by Progress
     

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

     
Back to Top