Why my Fiddler (debugger)doesn't capture any traffic on Win10?

2 posts, 0 answers
  1. 咪 avatar
    1 posts
    Member since:
    Nov 2017

    Posted 15 Nov 2017 Link to this post

    Few months ago , I still used XP operating system, 

    and Fiddler worked fine on it. 

    Then , due to some problem I faced on XP, 

    I decided to install Win10 and abandon XP, 

    after installing Fiddler and start on Win10, 

    As the title said. 

    I realized that Fiddler almost didn"t capture any traffic...... 

     

    No matter what browser I use,it always could only capture one. 


    The only one traffic Fiddler could capture was the website of Fiddler 

    I recorded a video about the problem I mentioned above 

    If my description isn"t clear , you could look this 

    https://www.youtube.com/watch?v=CFc8rCry6F4 

    (Although the language I use is Chinese,the same option can still be found acrroding to the sequence) 

    (Extnesion) 

    there is its message from log: 

    20:50:09:6858 Fiddler Running... 
    20:50:09:7054 Windows 8+ AppContainer isolation feature detected. 
    20:50:09:7419 AutoProxy failed. Disabling for this network. 
    20:50:44:7894 WinINET Registry change detected. Verifying proxy keys are intact... 
    20:50:44:7899 WinINET API indicates that Fiddler is no longer attached.

  2. Simeon
    Admin
    Simeon avatar
    195 posts

    Posted 04 Dec 2017 Link to this post

    Hello,

    Sorry for the late reply and thank you for the video! I can see that in the status bar of Fiddler it says 'Capturing' which means that your system proxy settings point to Fiddler. This means that if you set your browser's proxy to use the system proxy settings, you should see the traffic being captured by Fiddler.

    However, the log message, which you provided, mentions that the system proxy settings were changed, which means that they do not point to Fiddler anymore:
    20:50:44:7894 WinINET Registry change detected. Verifying proxy keys are intact... 
    20:50:44:7899 WinINET API indicates that Fiddler is no longer attached.

    I believe that when Fiddler reported that, you saw a yellow button on top of it saying: 'The system proxy was changed. Click to reenable capturing.'

    This means that maybe you have a program which is changing the system proxy settings like zScaler, for example. Please, try to stop the other program which is changing your system proxy settings, as well, or reconfigure it to use Fiddler as a proxy, which by default listens on 127.0.0.1:8888

    Regards,
    Simeon
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top