why it is showing this error

4 posts, 0 answers
  1. Azeheruddin khan
    Azeheruddin khan avatar
    32 posts
    Member since:
    Mar 2010

    Posted 14 Jul 2010 Link to this post

    Telerik - WebUI Test Studio
    ---------------------------
    Failed to launch the browser. Error: System.TimeoutException: Wait for condition has timed out

       at ArtOfTest.Common.WaitSync.CheckResult(WaitSync wait, String extraExceptionInfo)

       at ArtOfTest.Common.WaitSync.For[T](Predicate`1 predicate, T target, Boolean invertCondition, Int32 timeout)

       at ArtOfTest.Common.WaitSync.For[T](Predicate`1 predicate, T target, Int32 timeout)

       at ArtOfTest.WebAii.Design.RecorderWindowManager.WaitForRecorderCallBackReady()

       at ArtOfTest.WebAii.Design.RecorderWindowManager.<>c__DisplayClass5.<EnsureActiveBrowser>b__4()
    ---------------------------
    OK  

  2. Ray Lin
    Ray Lin avatar
    20 posts
    Member since:
    May 2010

    Posted 14 Jul 2010 Link to this post

    This is the common error. You need to set the sleep time longer. It should work.

    Ray
  3. Missing user
    Missing user avatar

    Posted 14 Jul 2010 Link to this post

    Hello Azeheruddin,

    Thanks for the question and your trial of WebUI Test Studio.

    Quick Edit: After looking at the error again, it looks like this is happening when trying to launch the Recording Window.

    Please also make sure your system is configured for automation as in these videos for Vista, XP, Servers 03/08. Windows 7 is the same as Vista.

    It looks like you have downloaded JustCode, so there maybe a current conflict with WebUI and JustCode. Please let us know if you do have JustCode installed.

    If configuring the system as in the videos does not fix the problem, please try disabling the Add Ons for Internet Explorer except for: WebUI TestStudio Recorder, WebAii Test Execution Extension, Discuss

    Please post back if the above does not fix the problem along with the following information:

    - if WebUI was installed with a user account that is part of the Admin Group
    - if you are using a version of Windows or IE that is an international version besides English(US)
    - it does not look like you downloaded a previous version of WebUI, but please respond back if you did install a previous WebUI version on the machine

    Regards,
    Nelson Sin
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  4. Cody
    Admin
    Cody avatar
    3354 posts

    Posted 20 Jul 2010 Link to this post

    Hi Ray Lin,

    Nelson is taking a few days off. Did you get this problem resolved? Do you need any further assistance with this?

    All the best,
    Cody
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Back to Top