Why can't I disable OA DSW on VS Startup

Thread is closed for posting
7 posts, 1 answers
  1. Stuart Hemming
    Stuart Hemming avatar
    1622 posts
    Member since:
    Jul 2004

    Posted 08 Aug 2010 Link to this post

    Please see SS1.jpg (attached).

    Why can't I disable the DSW?

    I've cross-posted this to the JustCode forum.

    -- 
    Stuart
  2. Zoran
    Admin
    Zoran avatar
    534 posts

    Posted 10 Aug 2010 Link to this post

    Hi Stuart Hemming,

     Can you please re-try attaching that image, as there is no attachment visible on our side. Probably some problem has popped up while doing the attachment. Sorry for the inconvenience.

    Sincerely yours,
    Zoran
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Stuart Hemming
    Stuart Hemming avatar
    1622 posts
    Member since:
    Jul 2004

    Posted 10 Aug 2010 Link to this post

    Here you go.

    -- 
    Stuart
  4. Damyan Bogoev
    Admin
    Damyan Bogoev avatar
    581 posts

    Posted 10 Aug 2010 Link to this post

    Hello Stuart Hemming,

    To disable the DSW addin you should uncheck the Startup setting for the Telerik OpenAccess DSW from the Addin manager.
    Other approach you could use here is to remove the addin registration:
    - Go to [Telerik OpenAccess InstallDir]\ Data Services Wizard\IDEIntegrations\Addins;
    - Rename DSW%XX%AddIn.AddIn to DSWXXAddIn.AddIn.bak or just remove it where %XX% is the version of the Visual Studio that you are using;
    Hope that helps.

    Regards,
    Damyan Bogoev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Stuart Hemming
    Stuart Hemming avatar
    1622 posts
    Member since:
    Jul 2004

    Posted 10 Aug 2010 Link to this post

    To disable the DSW addin you should uncheck the Startup setting for the
    > Telerik OpenAccess DSW from the Addin manager.
    OK. I know I'm not considered bright, but I knew that.

    This issue is that the checkbox you refer to is disabled. I'm sure that that was clear in the screenshot I sent you. Why is it disabled. 

    I shouldn't have to go around renaming files to disable addins.

    -- 
    Stuart
  6. Answer
    Damyan Bogoev
    Admin
    Damyan Bogoev avatar
    581 posts

    Posted 11 Aug 2010 Link to this post

    Hi Stuart Hemming,

    Please accept my apologies regarding my previous answer.

    It seems that this is caused because the .addin files are read-only. This happens on Vista and Windows 7 due to UAC since these files are in Program Files folder.
    The only thing you should do is to run VS.NET as administrator. Now all checkboxes will be enabled.
    Hope that helps.


    Regards,
    Damyan Bogoev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. Stuart Hemming
    Stuart Hemming avatar
    1622 posts
    Member since:
    Jul 2004

    Posted 11 Aug 2010 Link to this post

    Damyan 

    > Please accept my apologies regarding my previous answer.
    No worries.

    > It seems that this is caused because the .addin files are read-only. This happens on
    > Vista and Windows 7 due to UAC since these files are in Program Files folder.
    Now that explains a lot; the TabsStudio addin installs in the C:\Users\<username>\Documents\Visual Studio 2008\Addins folder.

    > The only thing you should do is to run VS.NET as administrator. Now all checkboxes will be enabled.
    > Hope that helps.
    You're absolutely correct. I was thrown by the fact that although I'm an admin user I don't appear to run the programs as administrator.
    B*%&$£ Windows! :-)

    Sorted.

    -- 
    Stuart
Back to Top