Weird selection behavior when editing forum post

2 posts, 1 answers
  1. Mihajlo
    Mihajlo avatar
    38 posts
    Member since:
    Aug 2018

    Posted 04 Oct 2018 Link to this post

    Not sure where to put this. When I write a new post, and have the caret at the end of the post, and press Shift+Ctrl+Left I select the last word.

    • But if start typing then the space before the last word will also be deleted with the selection, which is not expected.
    • If instead of typing I press Shift+Ctrl+Left again the selection will not expand to another word, but disappear altogether. The caret jumped from selection beginning to selection end. And if I press Shift+Ctrl+Left for the third time a new selection will appear, without the last word.
    • But get this. If I don't raise the Left key in previous use case then selection will retain the last word. Caret will not jump.

    If the caret is in the middle of the text and I repeat Shift+Ctrl+Left until the beginning of post, and continue repeating, then the caret will also jump from selection start to selection end and the selection will shrink with each key press. The expected behavior is for caret to not jump, and selection to remain the same.

    But this only happens if I raise Left key at least once. Otherwise the selection remains unchanged while I hold Shift+Ctrl+Left.

  2. Answer
    Simeon
    Admin
    Simeon avatar
    3 posts

    Posted 12 Oct 2018 Link to this post

    Hello Mihajlo,

    Sorry for the caused inconvenience.

    We've taken a look at the issues and reproduced it on our side. Since we are using an asp.net control for the text editor we have reported the issues to the respected team.

    Thank you for contacting us!

    Regards,
    Simeon
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top