Warning when --uglify build

2 posts, 0 answers
  1. Jorge
    Jorge avatar
    3 posts
    Member since:
    Feb 2017

    Posted 15 Aug Link to this post

    Hi,

    I am getting this warning (many lines) in android only when I use the --uglify flag during build: 

    JS: Warning: 't' is not supported when 'showOverNavigation' is set to 'true'.
    JS: ERROR RangeError: Maximum call stack size exceeded

    I am using the tns-template-drawer-navigation-ng and changed the sideDrawerTransition to FadeTransition in all my pages. The warning is not thrown if a use webpack without the --uglify flag. 

    Nativescript: 3.1.3

    tns-core-modules: 3.1.1

    tns-android: 3.1.1

    nativescript-telerik-ui-pro: 3.0.4

    Regards,

     

    Jorge Cruz

     

  2. Nikolay Iliev
    Admin
    Nikolay Iliev avatar
    294 posts

    Posted 16 Aug Link to this post

    Hello Jorge Cruz,

    Thank you for your interest in NativeScript and for contacting us about this issue.
    I can confirm that indeed at this very moment the described scenario is fully reproducible when using RadSideDrawer with FadeTransition and WebPack bundling with uglify. We have logged this one as a bug here.

    Our WebPack related developers are looking into this problem and you can track its development and possible workarounds/fixes in this issue. Once a suitable solution is provided the information will be updated and if needed a new version of the plugin will be released.

    Sorry for any inconvenience caused by this issue and once again thank you for reporting this case to us - I am adding to your account Telerik points as a bonus for the found bug

    Regards,
    Nikolay Iliev
    Progress Telerik
    Did you know that you can open private support tickets which are reviewed and answered within 24h by the same team who built the components? This is available in our UI for NativeScript Pro + Support offering.
Back to Top