VS Error adding to Toolbox

6 posts, 0 answers
  1. Ron
    Ron avatar
    3 posts
    Member since:
    Aug 2008

    Posted 18 Aug 2008 Link to this post

    Hi,

    I've d/l'd the RadControls for Silverlight trial. I can load 'RadControls for Silverlight 2.sln". The demo runs fine on my system locally (VS2008 with latest SL beta).

    With that project loaded, however (or any other Silverlight project, for that matter), I get an error when attempting to add the RadControls to the Toolbox:

    "There was an error loading types from assembly 'C:\...\Telerik.Windows.Controls.dll'
    'Could not load file or assembly 'System.Windows, Version=2.0.5.0, Culture... or one of its dependencies. The system cannot find the file specified.'"

    Any suggestions appreciated.
  2. Valentin.Stoychev
    Admin
    Valentin.Stoychev avatar
    2198 posts

    Posted 19 Aug 2008 Link to this post

    Hi Ron,

    check-out this KB article:
    http://www.telerik.com/support/kb/article/b454K-babb-b454T-cmg-b454c-cmg.aspx

    Let us know if you still have any problems.

    Kind regards,
    Valentin.Stoychev
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  3. Ron
    Ron avatar
    3 posts
    Member since:
    Aug 2008

    Posted 19 Aug 2008 Link to this post

    Thanks Valentin,

    Don't know where the comments go, but I'm pretty sure that's the KB article I've already posted a comment on, i.e., it doesn't mention what to do in case of an error message like the one I described above.

    Newbie .NETter, here, so this may be a VS or .NET issue (not Telerik), but if you have suggestions I'd be grateful.

    cheers,

    Ron
  4. Valentin.Stoychev
    Admin
    Valentin.Stoychev avatar
    2198 posts

    Posted 20 Aug 2008 Link to this post

    Hi Ron,

    Hm... this is strange. Are you doing the exact steps as in the KB? Is the project of type Silverlight Application? Is the project working when you run it or you have problems only with the toolbox?


    All the best,
    Valentin.Stoychev
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  5. Ron
    Ron avatar
    3 posts
    Member since:
    Aug 2008

    Posted 20 Aug 2008 Link to this post

    Ran through it again - thanks.

    I scanned step 5 and missed "...choose the Silverlight Components tab...". It's not clear to me why that should make a difference, but it does.

    Working now, thanks.

    Might help to break that tab selection out as a step on its own, although I'm sure that most folks familiar with .NET and/or Silverlight will do this automatically.

    Cheers!
  6. Valentin.Stoychev
    Admin
    Valentin.Stoychev avatar
    2198 posts

    Posted 21 Aug 2008 Link to this post

    Hi Ron,

    I'm glad you were able to solve your problem. Let us know if you have any feedback/confusion while using the controls.

    Thanks!

    Kind regards,
    Valentin.Stoychev
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Back to Top