This is a migrated thread and some comments may be shown as answers.

vs 2010 domain service wizard

1 Answer 12 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
richard
Top achievements
Rank 1
richard asked on 24 Mar 2011, 12:05 PM
I am not sure where to post this problem so here it will be.

I did not have this problem until I installed Telerik Premium but at the same time I installed vs2010 sp1 so I am not sure where the problem lies. Hopefully someone here can help me.

When I try to create a domainservice class with a file name of customer.myDomainService the file is created ok; however, on the next screen of the wizard where you pick which entities will be in the service I cannot change the domain service class name from customer.myDomainService to myDomainService. The wizard will not let me edit that field.

I like to keep each entity in a seperate file so I have been doing this for sometime, until now.

Any help would be appreciated.

thanks,
Richard

1 Answer, 1 is accepted

Sort by
0
richard
Top achievements
Rank 1
answered on 24 Mar 2011, 12:10 PM
Ok I have been working on this issue for a couple of days before posting here....well of course as soon as I post the above message I do some more searching and come across the answer here:

http://forums.silverlight.net/forums/p/209161/491790.aspx

Evidently in WCF RIA SP1 (included in vs2010 sp1) the field was made read only....wish they would have greyed the field out so we know that.

Richard
Tags
General Discussions
Asked by
richard
Top achievements
Rank 1
Answers by
richard
Top achievements
Rank 1
Share this question
or