Virtualized items don't move with the map.

4 posts, 0 answers
  1. Clint Singer
    Clint Singer avatar
    133 posts
    Member since:
    Oct 2012

    Posted 06 Nov 2009 Link to this post

    Hi,

    When trying the MAP CTP Items Virtualization demo when one moves the map the items on top of the map move in time with the mouse but the map behind doesn't keep up with the items.  I am assuming that you already know this because it is fairly obvious but I would like to know if this will be fixed in the near future?

    Cheers,
    Clint
  2. Bartholomeo Rocca
    Bartholomeo Rocca avatar
    247 posts
    Member since:
    May 2006

    Posted 07 Nov 2009 Link to this post

    Hello Clint,

    I believe currently you can disable the map move animation through the RadMap.UseSpringAnimations property -- check the "City Demographics" example.


    Greetings,
    Bart.
  3. Clint Singer
    Clint Singer avatar
    133 posts
    Member since:
    Oct 2012

    Posted 23 Nov 2009 Link to this post

    The spring animations are nice so maybe a feature request should be to support "springs" in other layers. 

    I am putting that out as a feature request.  So setting a new location wouldn't render that item immediately but rather the items would spring with the map.

    Cheers,
    Clint
  4. Giuseppe
    Admin
    Giuseppe avatar
    2363 posts

    Posted 24 Nov 2009 Link to this post

    Hi Clint,

    Indeed enabling spring animations support for the custom rendered layers is in our TODO list and we hope we will be able to provide it for the Q1 2010 release.


    All the best,
    Manuel
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
Back to Top