This question is locked. New answers and comments are not allowed.
IIS returns a 404 error when the uploaded file size is > the maxContentLength setup in web.config. I'm checking for a 404 in e.XMLHttpRequest.status when there is an error to display a message to users that their file is too large. Tracing the request in fiddler clearly shows a 404 was returned by the server, and IE Dev Tools Network Capture shows a 404 was returned, but the value of e.XMLHttpRequest.status in IE 9/8 is 500 instead of 404.
e.XMLHttpRequest.responseText contains the error message returned from the server wich says it was a 404. e.XMLHttpRequest.status is correct (404) in chrome.
e.XMLHttpRequest.responseText contains the error message returned from the server wich says it was a 404. e.XMLHttpRequest.status is correct (404) in chrome.