This is a migrated thread and some comments may be shown as answers.
Upgrading references
5 Answers 39 Views
This is a migrated thread and some comments may be shown as answers.
This question is locked. New answers and comments are not allowed.
lkeel
Top achievements
Rank 1
lkeel asked on 22 Mar 2010, 09:01 PM
Maybe I am missing something here, but it appears that in order to use the Telerik.OpenAccess within my aspx page, I have to register the dll at the top of the page.  Well in that registration, it only seems to work if I put the version number in there.  If I take the version section out of the register line then the application will not run.  The problem is that every time I upgrade versions, my site quits working and I have to spend hours trying to go back and get things fixed to new version.  Could someone please tell me what I am doing wrong or if there are plans to make this easier in the near future?

Thanks,
Lee

5 Answers, 1 is accepted

Sort by
0
Alexander
Telerik team
answered on 23 Mar 2010, 04:47 PM
Hello lkeel,

The version information cannot be excluded from the assembly references but OpenAccess already has a wizard that can update the references of all your projects and web pages when you upgrade the version of the product. Please refer to this article for details about the upgrade procedure. Hope that helps.

Best wishes,
Alexander
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
0
lkeel
Top achievements
Rank 1
answered on 23 Mar 2010, 09:21 PM
That article did help and I did run that, but my web.config file no longer worked. I had a <backendconfigurationname>mssqlConfiguration</backendconfigurationname> in my file before and everything worked fine, but now I had to add the lines:
<backendconfigurations>
<backendconfiguration id="mssqlConfiguration" backend="mssql">
<mappingname>mssqlMapping</mappingname>
</backendconfiguration>
</backendconfigurations>
<mappings current="mssqlMapping">
<mapping id="mssqlMapping" />
</mappings>
to my web.config file to get things to work.  So was there a breaking change about the backendconfigurations & mappings in this build vs previous builds?  
0
Alexander
Telerik team
answered on 24 Mar 2010, 08:57 AM
Hello lkeel,

I do not think that there are any changes made in that direction at all. Maybe the UpdateDatabase property of the project somehow has changed to True. In such cases it is required that the mapping configuration is present in the config file.
However to make sure that only the invalid references will be fixed and nothing else, you can disable the mapping validations of the Check Settings wizard and run only the upgrade functionality. To do that, for each project in the Targets treeview disable all validators from the Validators treeview and enable only the "Update assembly references" validator.

Greetings,
Alexander
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
0
lkeel
Top achievements
Rank 1
answered on 26 Mar 2010, 06:53 PM
I used the tool as suggested and it worked to some degree.  The problem is that something has changed in OpenAccess.  I did not have the backendconfigurations and mappings in the web.config.  These settings were in the app.config file in the data access dll.  Now the settings apparently have to be in the web.config file.  Now I understand things change, but this is a breaking change that has taken me hours to figure out.
0
Alexander
Telerik team
answered on 01 Apr 2010, 12:05 PM
Hi lkeel,

Sorry that I am going to repeat myself but I have just verified that the backendconfiguration node is not needed in the executing project unless the UpdateDatabase property of that project is set to True. I also verified that we have not done any changes in that area recently.
Can you please make sure that this property is set to False for your project? Just press F4 while the project is selected in the Solution Explorer and you should see it. This option should be enabled only when you are doing forward mapping.

Best wishes,
Alexander
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
Tags
Design Time (Visual Designer & Tools)
Asked by
lkeel
Top achievements
Rank 1
Answers by
Alexander
Telerik team
lkeel
Top achievements
Rank 1
Share this question
or