Upgrade Error

3 posts, 0 answers
  1. Hakki
    Hakki avatar
    47 posts
    Member since:
    Sep 2012

    Posted 12 Apr 2013 Link to this post


    When I try to upgrade to the latest version (v.2013.1.403.1050), I get the following errors:



    It also breaks some of my controls saying Expression_Dark theme can't be found.

    I have upgraded many times before and this is the first time I ran into a problem.

    Any ideas what is going on?
  2. Chavdar Dimitrov
    Chavdar Dimitrov avatar
    104 posts

    Posted 17 Apr 2013 Link to this post


    Thank you for reporting this.

    It seems that the upgrade log creation failed for some reason. I've tried to reproduce the issue, but with no success. Is it possible to send us a project that reproduces the issue?

    As a temporary workaround, you could try to disable the 'Show upgrade log when the Upgrade Wizard finishes the update' option. This should prevent the wizard from the crash.

    Regarding the Expression_Dark problem, there are several possible scenarios:
    1. The reference to the theme assembly (Telerik.Windows.Themes.Expression_Dark.dll) has been removed (if the theme was referred from an assembly)
    2. The XAML resources has been removed (if the theme was referred from a XAML resource)
    3. The controls assemblies were updated from NoXaml version to a standard version

    The first two scenarios might have been caused by the Upgrade Wizard crash, so please try the workaround above and check again if the problem persists. The third one is self explaining - the fix is to choose the correct distribution at the fist step of the upgrade wizard.

    I hope this information is helpful. Let me know if I can be of further assistance.

    Kind regards,
    the Telerik team

    Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

  3. Hakki
    Hakki avatar
    47 posts
    Member since:
    Sep 2012

    Posted 14 May 2013 Link to this post

    Oh sorry, forgot about this.

    I have solved the upgrade issue by using the wizard in the Telerik toolbar in VS (instead of the "upgrade now" when it pops up). Although it seems to do the same thing, it worked.

    As for Expression_Dark, for some reason it didn't make the cut when being upgraded so I had to delete the existing reference and add a reference for that .dll manually from the new Telerik control folder containing the .dll's.

    I have upgraded 2 or so times since this thread I believe and they all went flawlessly.

    Sorry I can't give more solid data for you guys to work with but it's all good now.
Back to Top