TreeView drag and drop error?

4 posts, 1 answers
  1. Gabriele Eigel
    Gabriele Eigel avatar
    9 posts
    Member since:
    Jan 2009

    Posted 18 Jun 2009 Link to this post

    Hi, I have a tree view with drag and drop implementation and I get sometimes an error message like :

    {System.NullReferenceException: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.
       bei Telerik.Windows.Controls.RadTreeViewItem.GetIndentQueue()
       bei Telerik.Windows.Controls.RadTreeViewItem.RenderIndent(Boolean recursive)
       bei Telerik.Windows.Controls.RadTreeViewItem.Render(Boolean recursive)
       bei Telerik.Windows.Controls.RadTreeViewItem.OnItemsChanged(NotifyCollectionChangedEventArgs e)
       bei System.Windows.Controls.ItemsControl.RaiseOnItemsChanged(NotifyCollectionChangedEventArgs e)
       bei System.Windows.Controls.ItemsControl.OnCollectionChanged(Object sender, NotifyCollectionChangedEventArgs e)
       bei System.Collections.Specialized.NotifyCollectionChangedEventHandler.Invoke(Object sender, NotifyCollectionChangedEventArgs e)
       bei System.Collections.ObjectModel.ObservableCollection`1.OnCollectionChanged(NotifyCollectionChangedEventArgs e)
       bei System.Collections.ObjectModel.ObservableCollection`1.InsertItem(Int32 index, T item)
       bei System.Collections.ObjectModel.Collection`1.Add(T item)
       bei Roche.Prisma.Cat.HierarchyMaintenanceControl.OnDropInfo(Object sender, DragDropEventArgs e)}

    Any idea why? Thanks a lot for each help.
    Regards,
         Gabriele
  2. Answer
    James
    James avatar
    119 posts
    Member since:
    Mar 2009

    Posted 18 Jun 2009 Link to this post

    Hi Gabriele,
    I think this bug has been fixed. Do you have the latest binaries? (If so, make sure you delete any cached versions.) I've had the same error message, but not since the newer version was released a few weeks ago.
    James.
  3. Gabriele Eigel
    Gabriele Eigel avatar
    9 posts
    Member since:
    Jan 2009

    Posted 19 Jun 2009 Link to this post

    Hi James,

    no, I don't have the latest version (jet :-)), thank you for this information. Now I have a spark of hope.
    Regards, Gabriele
  4. Gabriele Eigel
    Gabriele Eigel avatar
    9 posts
    Member since:
    Jan 2009

    Posted 19 Jun 2009 Link to this post

    After getting the new binaries I haven't the problem anymore, but some others (see posting in the RadTreeView forum). Thank's, Gabriele
Back to Top