This is a migrated thread and some comments may be shown as answers.

Sproc Domain Method - Unable to retrieve the result shape

1 Answer 9 Views
Databases and Data Types
This is a migrated thread and some comments may be shown as answers.
This question is locked. New answers and comments are not allowed.
TIOS
Top achievements
Rank 1
TIOS asked on 18 Jul 2013, 02:27 PM
Hi,

Seem to be having issues with ORM.  I put it down being not latest version so installed latest version.  This seems to fix it for a while.

However, now intermittently when I tried to edit an existing domain method for a mssql sproc then click retrieve results im getting "Unable to retrieve the result shape.".  This is very annoying to say the least, the only solution is to delete the domain method then manually edit the rlinq xml and remove the sproc then readd it from start.

I've checked App.Config and it is correct also when you readd it has no issues then.

1 Answer, 1 is accepted

Sort by
0
PetarP
Telerik team
answered on 22 Jul 2013, 03:26 PM
Hi Chris,

 Can you please share the definition of your stored procedure? Basically the exception you are seeing can be caused by either one of the following:
1. The result set contains fields that are not supported by our converters. (This should not be the case as initially you are able to read it).
2. The reading of the result times out due to a problem with the server.

I tried executing the same workflow on my side and it seems that everything is working as expected.

Regards,
Petar
Telerik
OpenAccess ORM Q2 2013 brings you a more powerful code generation and a unique Bulk Operations support with LINQ syntax. Check out the list of new functionality and improvements shipped with this release.
Tags
Databases and Data Types
Asked by
TIOS
Top achievements
Rank 1
Answers by
PetarP
Telerik team
Share this question
or