SL3 vs SL4

5 posts, 0 answers
  1. Maria
    Maria avatar
    12 posts
    Member since:
    Aug 2010

    Posted 05 Jul 2011 Link to this post

    Hi,

    I had a project on .NET 3.5 with SL3 and MEF, and I was using 2010.2.924.1030. 
    I just upgraded to the latest version of Q12011 controls for SL4 and I keep getting the following error:

    Could not load type 'System.ComponentModel.BrowsableAttribute' from assembly 'Telerik.Windows.Controls, Version=2011.1.704.1040, Culture=neutral, PublicKeyToken=5803cfa389c90ce7'.

    I don't see this type in the Onject Browser, although it was there in the old version. 
    Can you please give me an idea about how to fix this? Thank you!
  2. Vlad
    Admin
    Vlad avatar
    11100 posts

    Posted 06 Jul 2011 Link to this post

    Hello Maria,

     You cannot use our Silverlight 3 assemblies in Silverlight 4 project. You need our Silverlight 4 assemblies (all official release for almost a year ago). 

    Regards,
    Vlad
    the Telerik team

    Register for the Q2 2011 What's New Webinar Week. Mark your calendar for the week starting July 18th and book your seat for a walk through of all the exciting stuff we will ship with the new release!

  3. Maria
    Maria avatar
    12 posts
    Member since:
    Aug 2010

    Posted 06 Jul 2011 Link to this post

    hi Vlad!

    Thanks for your reply. 
    Sorry if I wasn't clear enough. 

    I converted my project to .Net 4 and Silverlight 4 and I was trying to compile it with your new assemblies (Q12011), but I was getting this strange error.
  4. Vlad
    Admin
    Vlad avatar
    11100 posts

    Posted 06 Jul 2011 Link to this post

    Hi Maria,

     Can you send us this project (via support ticket) to check it locally what's going on?

    All the best,
    Vlad
    the Telerik team

    Register for the Q2 2011 What's New Webinar Week. Mark your calendar for the week starting July 18th and book your seat for a walk through of all the exciting stuff we will ship with the new release!

  5. Maria
    Maria avatar
    12 posts
    Member since:
    Aug 2010

    Posted 07 Jul 2011 Link to this post

    This was my issue, sorry about that. 
    I can't find a way to delete the thread, but it's not relevant anymore. 

    Thank you for your time anyway!
Back to Top