Silverlight Version

4 posts, 0 answers
  1. pratik mehta
    pratik mehta avatar
    17 posts
    Member since:
    May 2010

    Posted 01 Jul 2010 Link to this post

    Hi

    Can we use Silverlight 4 controls in Visual Studio 2010 using FrameWork 3.5 not  Framework 4.0?


    Thanks

    Pratik Mehta
  2. Yavor Georgiev
    Admin
    Yavor Georgiev avatar
    982 posts

    Posted 01 Jul 2010 Link to this post

    Hi pratik mehta,

     What do you mean, use Silverlight 4 controls with Framework 3.5? Silverlight is a distinct technology in its own right and does not depend on any version of the .NET Framework. Could you please explain a bit more about what you want to do?

    Best wishes,
    Yavor Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. pratik mehta
    pratik mehta avatar
    17 posts
    Member since:
    May 2010

    Posted 01 Jul 2010 Link to this post

    Ok

    Right now we have Visual studio 2008 installed in our machine. and we want to by telerik SL4 controls.

    As per my understanding we can not use Telerik SL4 controls in VS 2008, Correct me if i am wrong.

    Now we are planning to Move on VS 2010 but some restriction on Prod Server we can not install Framework 4.0 over there.

    So my question is if we Create Silverlight Project in VS2010 by selecting Framework 3.5 still we can use Telerik SL4 control in that project , correct?


    Thanks

    Pratik Mehta
  4. Yavor Georgiev
    Admin
    Yavor Georgiev avatar
    982 posts

    Posted 01 Jul 2010 Link to this post

    Hi pratik mehta,

     Our Silverlight controls can run on both Silverlight 3 and Silverlight 4. However, starting with version Q2, we will no longer ship SL3 versions of our controls.

    So, you can use the SL3 version of our Silverlight Q1 SP2 with Visual Studio 2008. However, for SL4 binaries and our next versions, you need Visual Studio 2010, both on your dev machines and on your build machines.

    In short, if you wish to use Silverlight 4, then you need to have VS10. Do note, however, that this restriction is not imposed by Telerik, but rather by Microsoft, because Visual Studio 2008 does not support Silverlight 4.

    Sincerely yours,
    Yavor Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Back to Top