This is a migrated thread and some comments may be shown as answers.

Setting default startup language GridView version 2012.2.607.1050

5 Answers 44 Views
GridView
This is a migrated thread and some comments may be shown as answers.

5 Answers, 1 is accepted

Sort by
0
Accepted
Dimitrina
Telerik team
answered on 17 Oct 2012, 07:25 AM
Hello,

I have checked how the code from the article is applied when using version 2012.2.607.1050. All is working fine. Please find the test project attached for a reference.

Regards,
Didie
the Telerik team

Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

0
TMatt
Top achievements
Rank 2
answered on 23 Oct 2012, 10:43 AM
hi, we have similar Probolem.

After Upgrade to Q3 we have partial wrong Language. In our case we get wrong Date formats.

See my screenshot.
0
Yoan
Telerik team
answered on 23 Oct 2012, 01:26 PM
Hello Tobias,

 This is breaking change for the RadGridView. You should set the Language property to be the CurrentCulture and the GridView will be formatted based on it. You can set it like so: 

<telerik:RadGridView
    Name="clubsGrid"
    ItemsSource="{Binding Clubs}"
    AutoGenerateColumns="False"
    Language="de">

I believe that will help you.


Regards,
Yoan
the Telerik team

Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

0
TMatt
Top achievements
Rank 2
answered on 27 Oct 2012, 12:08 PM
What kind of shit is that?

Our Silverlight Programm is multilanguage, and now i have to hardcode the Grid?
Other Modules works out of the box correct (Use User System Language). This change is really bullshit.

0
Yoan
Telerik team
answered on 31 Oct 2012, 01:50 PM
Hello Tobias,

Maybe I was not clear enough in the previous post. You do not need to hardcode anything. Please excuse me for that.

As you can see from the GridView's Release Notes,  now the Culture used for formatting the GridView is the one specified as a Language for it or for the containing UserControl. We have changed the behaviour of the GridView concerning culture settings to be consistent with the ones for the DataGrid. You should set the Language property to be the CurrentCulture and the GridView will be formatted based on it.

Please check this help article to find an example on how you could set the Language property based on the CurrentCulture.

Greetings,
Yoan
the Telerik team

Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

Tags
GridView
Asked by
Jorge
Top achievements
Rank 1
Answers by
Dimitrina
Telerik team
TMatt
Top achievements
Rank 2
Yoan
Telerik team
Share this question
or