Reverse map DB to classes wizzard gives an Error

Thread is closed for posting
2 posts, 0 answers
  1. julian Welby Everard
    julian Welby Everard avatar
    13 posts
    Member since:
    Mar 2009

    Posted 08 Jul 2010 Link to this post

    When I try and reverse map my DB to classes the wizzard gives the following error

    Could not find file 'C:\Users\julian.everard\AppData\Local\Temp\TblConsultant.Telerik.OpenAccess.vb'.

    Please try again after fixing the problem.

    NOTE: The settings made so far have been saved to the reversemapping.config file.


    Code was not deploped on my PC, I have just been given the project from SourceSafe to make some changes, the version of ORM we are using is 2009.3.1119

    1) Why?
    2) This is not a file In my project directory as this is in a totaly different place
    3) It must be generated as its in Temp so why is it not being found?

    any help would be most appriacated

    Julian
  2. Ady
    Admin
    Ady avatar
    589 posts

    Posted 08 Jul 2010 Link to this post

    Hello julian Welby Everard,

     Can you ensure that 2 tables are not mapped to 1 class. You can use the 'Tables' node and sort the grid by 'Class name'. This could be the most likely reason for the error. It is not allowed to map 2 tables to the same class using the Reverse mapping wizard.

    Best wishes,
    Ady
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Back to Top