This is a migrated thread and some comments may be shown as answers.

[Solved] RadEditor & Upgrade to WSS 3.0

3 Answers 113 Views
RadEditor
This is a migrated thread and some comments may be shown as answers.
This question is locked. New answers and comments are not allowed.
Adam Drewes
Top achievements
Rank 1
Adam Drewes asked on 25 Mar 2008, 06:57 PM
We are in the process of upgrading our server from WSS 2.0 to WSS 3.0. We have a custom solution built on top of WSS 2.0 using the RadEditor. When we installed WSS 3.0 onto the server, everything continued to work except for the RadEditor. It looks like it is trying to use the new WSS 3.0 Dlls. Do you know how we can force it to look back at the old Dlls?

Thanks,
Adam

Server Error in '/_wpresources' Application.


Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: File or assembly name Microsoft.SharePoint, or one of its dependencies, was not found.

Source Error:

Line 68:     <httpHandlers>
Line 69: <add verb="*" path="/_vti_bin/*.aspx" type="System.Web.UI.PageHandlerFactory, System.Web, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
Line 70: <add verb="*" path="*.aspx" type="Microsoft.SharePoint.ApplicationRuntime.SharePointHandlerFactory, Microsoft.SharePoint, Version=11.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" />
Line 71: </httpHandlers>
Line 72: <customErrors mode="On" />

Source File: C:\servername\web.config    Line: 70

Assembly Load Trace: The following information can be helpful to determine why the assembly 'Microsoft.SharePoint' could not be loaded.

=== Pre-bind state information ===
LOG: DisplayName = Microsoft.SharePoint, Version=11.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c
(Fully-specified)
LOG: Appbase = file:///C:/Program Files/Common Files/Microsoft Shared/Web Server Extensions/wpresources
LOG: Initial PrivatePath = bin
Calling assembly : (Unknown).
===

LOG: Redirect found in application configuration file: 11.0.0.0 redirected to 12.0.0.0.
LOG: Publisher policy file is not found.
LOG: No redirect found in host configuration file (C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\Aspnet.config).
LOG: Using machine configuration file from C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\config\machine.config.
LOG: Post-policy reference: Microsoft.SharePoint, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c
LOG: Attempting download of new URL file:///C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET Files/_wpresources/8916aa16/2a0627fe/Microsoft.SharePoint.DLL.
LOG: Attempting download of new URL file:///C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET Files/_wpresources/8916aa16/2a0627fe/Microsoft.SharePoint/Microsoft.SharePoint.DLL.
LOG: Attempting download of new URL file:///C:/Program Files/Common Files/Microsoft Shared/Web Server Extensions/wpresources/bin/Microsoft.SharePoint.DLL.
LOG: Attempting download of new URL file:///C:/Program Files/Common Files/Microsoft Shared/Web Server Extensions/wpresources/bin/Microsoft.SharePoint/Microsoft.SharePoint.DLL.
LOG: Attempting download of new URL file:///C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET Files/_wpresources/8916aa16/2a0627fe/Microsoft.SharePoint.EXE.
LOG: Attempting download of new URL file:///C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET Files/_wpresources/8916aa16/2a0627fe/Microsoft.SharePoint/Microsoft.SharePoint.EXE.
LOG: Attempting download of new URL file:///C:/Program Files/Common Files/Microsoft Shared/Web Server Extensions/wpresources/bin/Microsoft.SharePoint.EXE.
LOG: Attempting download of new URL file:///C:/Program Files/Common Files/Microsoft Shared/Web Server Extensions/wpresources/bin/Microsoft.SharePoint/Microsoft.SharePoint.EXE.


Version Information: Microsoft .NET Framework Version:1.1.4322.2407; ASP.NET Version:1.1.4322.2407

3 Answers, 1 is accepted

Sort by
0
Lini
Telerik team
answered on 27 Mar 2008, 08:14 AM
Hello Adam,

Were you using the RadEditor for SharePoint product (RadEditorSharePoint.dll) in your solution, or the normal RadEditor control (RadEditor.dll)?

Does the error occur only when you open a page with the editor? Try removing the line

<add verb="*" path="*.aspx" type="Microsoft.SharePoint.ApplicationRuntime.SharePointHandlerFactory, Microsoft.SharePoint, Version=11.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" />

from the web.config file in the RadControls folder and see if this fixes the problem.

From the error details it seems that the website is running under ASP.NET 1.1. It is trying to load the Microsoft.SharePoint assembly from WSS 3.0, but this cannot be done since the WSS 3.0 version is compiled for ASP.NET 2.0.

Best wishes, Lini
the Telerik team

Instantly find answers to your questions at the new Telerik Support Center
0
Adam Drewes
Top achievements
Rank 1
answered on 27 Mar 2008, 06:20 PM
Lini,

Thanks for your response.

Were you using the RadEditor for SharePoint product (RadEditorSharePoint.dll) in your solution, or the normal RadEditor control (RadEditor.dll)?

I am using the RadEditorSharePoint.dll.

Does the error occur only when you open a page with the editor? Try removing the line

<add verb="*" path="*.aspx" type="Microsoft.SharePoint.ApplicationRuntime.SharePointHandlerFactory, Microsoft.SharePoint, Version=11.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" />

from the web.config file in the RadControls folder and see if this fixes the problem.


Yes, it only occurs when I open a page with the RadEditor; however, I have looked in the wpresources\RadWebParts\2.0.x\RadControls\web.config and the <add> tag with the MicrosoftSharePoint.dll is not there. It is; however, in the C:\inetpub\servernamedir\web.config.

Should I remove it from the root web.config?
0
Lini
Telerik team
answered on 28 Mar 2008, 07:25 AM
Hello Adam,

If the control is included only in the application's web.config file, then you should not remove it. You can try removing the <bindingRedirect> element for the Microsoft.SharePoint assembly from the \Program Files\Common Files\Microsoft Shared\web server extensions\wpresources\Web.config file.

Kind regards,
Lini
the Telerik team

Instantly find answers to your questions at the new Telerik Support Center
Tags
RadEditor
Asked by
Adam Drewes
Top achievements
Rank 1
Answers by
Lini
Telerik team
Adam Drewes
Top achievements
Rank 1
Share this question
or