RadControls for Silverlight Q1 2009 Demo Application and blend

4 posts, 0 answers
  1. Curtis
    Curtis avatar
    2 posts
    Member since:
    Mar 2009

    Posted 16 Mar 2009 Link to this post

    Hi,
    I can build and run the demo application just fine, but when i try to look at the app.xaml or mainpage.xaml i get an error in preview mode that the document root is not supported in preview mode?  When i load it into blend i get all sorts of font errors and load errors.  Why?  Are the controls not compatible with blend?
  2. Hristo
    Admin
    Hristo avatar
    832 posts

    Posted 16 Mar 2009 Link to this post

    Hello Curtis,

    RadControls for Silverlight 2 are fully compatible with Blend. But the custom controls used in our QSF (Demo Application) may have some Blend issues. We will try to fix them all for the next service pack.
    Thanks for the feedback.

    Do not hesitate to contact us if you need more information.

    Greetings,
    Hristo
    the Telerik team


    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. Curtis
    Curtis avatar
    2 posts
    Member since:
    Mar 2009

    Posted 16 Mar 2009 Link to this post

    Thanks, but why will the app not preview in vs2008 either?
  4. Hristo
    Admin
    Hristo avatar
    832 posts

    Posted 16 Mar 2009 Link to this post

    Hello Curtis,

    There seem to be some issues with Design-time when your root element is ContentControl and this content control is defined in another assembly (this is our case - our Example control is ContentControl and is defined in Telerik.Windows.QuickStart assembly).
    We will try to fix this for the next service pack.

    Kind regards,
    Hristo
    the Telerik team


    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
Back to Top