RadComboBox Validation

5 posts, 0 answers
  1. arul bretto kumar abraham
    arul bretto kumar abraham avatar
    1 posts
    Member since:
    Oct 2009

    Posted 26 Mar 2010 Link to this post

    hi

    in my silverlight application im using telerik:radComboBox
    i can set validation  for this control
    the validation is working fine  when my combobox is non editable mode
    but when my radcombobox is editable the validation is working but the notification message is not working
    ?
  2. Konstantina
    Admin
    Konstantina avatar
    2332 posts

    Posted 29 Mar 2010 Link to this post

    Hi,

    Thank you for contacting us.

    This is a known issue and it is already fixed. Please migrate to the latest internal build available and the problem should be resolved.

    If you still experience problems please feel free to contact us again.

    Kind regards,
    Konstantina
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. balv
    balv avatar
    13 posts
    Member since:
    Apr 2010

    Posted 21 Jul 2010 Link to this post

    Hi all,
    I have just a problem with validation when using the new Q2 2010 (0714)  telerik released dll.
    I cannot show full error message when validation with RadCombobox and RadDatePicker( just have a very small red box appeared)
    I tested with normal ComboBox (Silverlight Control) and error message when validate is very good. But when I replace by RadComboBox then has this inconvenience.
    I guess because telerik inputcontrol.???

    Thanks in advance,
    Best regards,
    balv

  4. Ulrich Fiege
    Ulrich  Fiege avatar
    62 posts
    Member since:
    Sep 2005

    Posted 22 Jul 2010 Link to this post

    Hello i have also a question,
    i made some color changes (not in radcombo) in the office_blue theme after that i replaced it in my project.
    Now i get this errormessage in outputwindow:

    System.Windows.Data Error: Fehler bei Verbindung mit Index '0' in Objekt 'System.Collections.ObjectModel.ReadOnlyObservableCollection`1[System.Windows.Controls.ValidationError]' (Typ 'System.Collections.ObjectModel.ReadOnlyObservableCollection`1[System.Windows.Controls.ValidationError]'). BindingExpression: Path="(Validation.Errors)[0].ErrorContent" DataItem="Telerik.Windows.Controls.RadComboBox" (HashCode=17053313); Zielelement ist "Telerik.Windows.Controls.Chromes.ValidationTooltip" (Name="ValidationTooltip"); Zieleigenschaft ist "TooltipContent" (Typ "System.Object").


    I didn't change anything in the radcombo.xaml theme-file. What is the reason for this ValidationError?
    We are using latest RadControls_for_Silverlight_4_2010_2_0716 Version.
    Greetings ....
  5. Pana
    Admin
    Pana avatar
    748 posts

    Posted 23 Jul 2010 Link to this post

    Hi,

    The missing text in the tooltip should be fixed in the last internal build RadControls_for_Silverlight_4_2010_2_0716_DEV.zip.

    If you are using custom theme you may need to update the ValidationTooltip's ValidationTooltip.xaml with the attached one. And the TooltipContent property on the ValidationTooltip (where it is used) should be set to:

    TooltipContent="{Binding Path=(Validation.Errors), RelativeSource={RelativeSource TemplatedParent}}"

    Kind regards,
    Panayot
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Back to Top