This is a migrated thread and some comments may be shown as answers.

RadBusyIndicator crashing design view

5 Answers 86 Views
BusyIndicator
This is a migrated thread and some comments may be shown as answers.
Tommy
Top achievements
Rank 1
Tommy asked on 10 Jan 2012, 11:23 AM
Hi,

When we try and load a RadBusyIndicator control (v2.0.50727) in design view it crashes both Visual Studio 2010 SP1 and Expression Blend 4.0.20525.0. Obviously there's no problems in XMAL view and the control will build and work as expected, the problem only occurs when switching to design view, or when trying to drag and drop a new RadBusyIndicator. 

We also got the same results when tested on two other machines.

Any possible solutions I could try?

Thanks in advance!
Tommy

5 Answers, 1 is accepted

Sort by
0
Boyan
Telerik team
answered on 13 Jan 2012, 10:58 AM
Hello,

We are not able to reproduce the bad behavior. Design time is working as expected on our side when dragging new control to the design view from the VS toolbox. Could you please share which exact version of our controls you are using, we tested the issue with the latest version (2011.3 1220). Also what error are you given when the design time crashes?

Note that in order for the RadBusyIndicator to show on the design surface you have to set IsBusy property to true.

Greetings,
Boyan
the Telerik team

Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

0
Tommy
Top achievements
Rank 1
answered on 13 Jan 2012, 11:23 AM

Hi Boyan,

We're using the Q3 2011 release but haven't yet upgraded to the latest service pack, would this be likely to resolve the issue?

We don't get any error, VS/Blend simply crashes with a "Visual Studio has stopped working.." message. The control works fine when we add it via XMAL and build the application this way, the problem only occurs when we switch to design view.

We're also using other Teletrik controls such as TileView, DataGrid, DataForm..etc with no issues.

FYI, I remember reading that some people were experiencing crashes with Telerik controls and Visual SVN, we're currently Visual SVN 2.5.1 but then I suppose this wouldn't explain why it also crashes in Expression Blend?

Thanks
Tommy



0
Boyan
Telerik team
answered on 17 Jan 2012, 04:02 PM
Hello,

We have not fixed similar issue for Q3 SP1, so I am not sure that an upgrade will help. Also I am not getting such behavior with Q3(2011.3.1116) as well.

Could you please share how you are referencing your binaries and do you have design assemblies at the place where Telerik DLLs are situated? The design binaries are situated in the following folder if you have installed our controls with default installation:
C:\Program Files (x86)\Telerik\RadControls for Silverlight Q3 2011 SP1\Binaries\Silverlight\design

All the best,
Boyan
the Telerik team

Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

0
Vic
Top achievements
Rank 1
answered on 22 Nov 2012, 11:11 AM
Same Problem with me, after I upgraded from toolkit busy indicator to RadBusyIndicator the VS and Blend both crashes, simply commenting out the Busy indicator from XAML does not crash anymore.. this is frustrating.

anyone found a solution for this.

Vic
0
Boyan
Telerik team
answered on 27 Nov 2012, 08:58 AM
Hello Vic,

We are not able to reproduce the issue at our side. Maybe it is related to some Add on for VS, although this doesn't explain why it is crashing Blend as well. Could you please send us a sample project where the problem occurs so we can check it out and also share what OS and Silverlight SDK version you are using. This will greatly help us in pinpointing the issue and providing a fix I have attached a screenshot of my SL versions.

Kind regards,
Boyan
the Telerik team

Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

Tags
BusyIndicator
Asked by
Tommy
Top achievements
Rank 1
Answers by
Boyan
Telerik team
Tommy
Top achievements
Rank 1
Vic
Top achievements
Rank 1
Share this question
or