R# Test runner failing w/ JustMock

2 posts, 0 answers
  1. Jacob Rillema
    Jacob Rillema avatar
    8 posts
    Member since:
    Nov 2009

    Posted 22 Dec 2011 Link to this post

    When I run the R# Test runner inside of VS 2010 on the individual test methods while using JustMock the tests run as expected. While in the same test session I run all tests for the given class all my Mock arranges I have confirmed get called however the delegates inside never get executed.  I am sure something is running in a seperate process somewhere but seems to be a bit odd that we hit the arrange code but the mocks never take over and my actual code that I am trying to mock executes. Again this only happens when I select run all tests for the class. Is this a R# issue or a JustMock issue? Any feedback would be appreciated. I have confirmed the Mock.Arranges are not throwing any exceptions and the R# test runner runs from the project output folder where the just mock assemblies are located at. 

    One last thing to add when I run the Visual Studio Test Runner all the tests pass successfully.

  2. Ricky
    Ricky avatar
    467 posts

    Posted 23 Dec 2011 Link to this post

    Hi Jacob,
    Thanks again for pointing the issue. it's a known one with R# test runner where the profiling variables are not getting initialized properly. If you run the same test with TestDriven.Net RTM or MSTest runner it will work as expected.

    However, we created an issue to further investigate the problem which you can track here:

    Kind Regards,
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

Back to Top