This is a migrated thread and some comments may be shown as answers.

PhoneApplicationFrame blanks text in Mango beta emulator

2 Answers 26 Views
PhoneApplicationFrame
This is a migrated thread and some comments may be shown as answers.
This question is locked. New answers and comments are not allowed.
Gary Davis
Top achievements
Rank 2
Gary Davis asked on 28 May 2011, 04:27 PM
I have seen other forum posts about a similar problem related to tombstoning but this is the same problem but happens unrelated to tombstoning. On the first page transition forward, all text flashes and then is blanked out. Button borders still show. Click the back arrow and the original page displays with no text now. Deploying to the phone device (running current Nodo) still works.

I tried the current hotfix dll's (2011.1.516.1037) but it did not resolve the problem. Removing the RadPhoneAppFrame from app.xaml.cs solves the problem.

Thanks,
Gary Davis
Webguild.com

2 Answers, 1 is accepted

Sort by
0
Gary Davis
Top achievements
Rank 2
answered on 28 May 2011, 09:43 PM
Another problem I had with the new emulator was the webbrowser control just displayed white and Internet Explorer also didn't work. The troubleshooting tips indicated that display driver WDDM 1.1 was a requirement and I had only 1.0 (via dxdiag). Updating to the latest Nvidia drivers did not help with the IE problem.

I bought a new video card (Evga G210) and it solved my IE problems, I re-tried the PhoneAppFrame problem and it also is now working!

Gary
0
Deyan
Telerik team
answered on 31 May 2011, 07:19 AM
Hello Gary,

Thanks for writing.

It seems that the issues you experienced were related to incompatibilities caused by your previous video adapter and the driver.

It is good that you managed to resolve them, hopefully this will be helpful for other that might experience similar difficulties.

Do not hesitate to get back to us in case you have further questions or need assistance.

Regards,
Deyan
the Telerik team
Let us know about your Windows Phone 7 application built with RadControls and we will help you promote it. Learn more>>
Tags
PhoneApplicationFrame
Asked by
Gary Davis
Top achievements
Rank 2
Answers by
Gary Davis
Top achievements
Rank 2
Deyan
Telerik team
Share this question
or