This is a migrated thread and some comments may be shown as answers.

PDFViewer not printing

1 Answer 60 Views
PDFViewer
This is a migrated thread and some comments may be shown as answers.
Chris
Top achievements
Rank 1
Chris asked on 02 Nov 2012, 02:23 PM
We have used the PDFViewer in our application and printing a PDF does not work.  The printed version has any lines for tables or anything that is coloured in but no text prints.  If the PDF is just text then a blank piece of paper is produced

I have also tried uploading a PDF document to the demo site and that doesn't print correctly either
http://demos.telerik.com/silverlight/#PdfViewer/FirstLook

Thanks
Chris.

1 Answer, 1 is accepted

Sort by
0
Kammen
Telerik team
answered on 05 Nov 2012, 12:50 PM
Hi Chris,

This is a known issue with Silverlight 5 printing on postscript printers. Usually, it can be solved by installing the latest postscript divers on your printer. If this do not help, you can set the ForceVector property to false in order to have Silverlight properly fall back to the "old" bitmap printing that should work.

Hope this information will help you to solve this issue. If you have further problems do not hesitate to contact us.

Regards,
Kammen
the Telerik team

Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

Tags
PDFViewer
Asked by
Chris
Top achievements
Rank 1
Answers by
Kammen
Telerik team
Share this question
or