Out of browser support

3 posts, 0 answers
  1. ITServices
    ITServices avatar
    15 posts
    Member since:
    Nov 2007

    Posted 14 Jul 2009 Link to this post

    Hello,

    Have just been been playing with the fantastic new "Out of browser" SL3 feature but was disappointed to find it doesn't seem to work with the Telerik controls (RadControls_for_Silverlight_2009_2_701_DEV) - seem to just get a blank screen.

    This could of course just be our app but reading in another thread (http://www.telerik.com/community/forums/silverlight/silverlight3/getting-radtoolbar-to-work-quot-out-of-browser-quot.aspx)  that the RadToolBar is currently not compatible, I was wondering which controls are; currently compatible, being made compatible and impossible to be compatible (e.g. RadEditor presumably).

    Basically would like to know if you're happy that certain controls work "Out of browser" before I start to try and find a bug with our app.

    Best Regards,

    Nick
  2. Ivan
    Admin
    Ivan avatar
    519 posts

    Posted 15 Jul 2009 Link to this post

    Hello Nick,

    Actually the OOB issue is not because of a particular control but is due to the disabled DOM/scripting bridge. Indeed there isn't a web browser surrounding the SL plug-in. As you know in SL2 some small things are not implemented - for example mouse's wheel and right buttons' events. The price of having these pearls is the interaction with the scripting bridge which in turn reflects in the OOB issue. Of course wit the upcoming SP1 release (it is targeted at the end of the month) this problem will be fixed.

    Please note the RadHtmlPlaceholder and the RadEditor controls are not available in the OOB mode too.

    We hope this information will help you to plan your work better.

    Regards,
    Ivan
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. ITServices
    ITServices avatar
    15 posts
    Member since:
    Nov 2007

    Posted 15 Jul 2009 Link to this post

    Thank you,

    It's not a requirement for our app atm, just a nice to have so will be looking forward to the upcoming SP1 fixes.

    Best regards,

    Nick
Back to Top