ORM problems with Rackspace Cloud Sites

Thread is closed for posting
3 posts, 0 answers
  1. damian breland
    damian breland avatar
    2 posts
    Member since:
    Sep 2009

    Posted 11 Aug 2010 Link to this post

    Hello,

    I have an Asp.NET application running ORM 2010.1 on a shared hosting account.  I am trying to migrate the app to Rackspace Cloud Sites.  They have two different addresses for the MsSQL DB server depending in you are running from external or internal to their network.  I can connect fine from my dev machine (external), but not when I deploy the app to their network.  The request times out while trying to initialize ObjectScopeProvider.  I have tried many configuration combinations to try to get this working.  I have also tried upgrading to 2010.2 with no luck. 

    I have also built another solution (split web/class projects) with the new domain model functionality.  Same problem - cannot initialize context.  I have built a test page that loads a RadGrid from a SQLDataSource, which works fine (internally & externally).

    Does any of this sound familiar to anyone?  Any issues with runtime vs design time database addresses?  Anyone running on Rackspace cloud Sites with ORM?

    Thanks - Damian
  2. Damyan Bogoev
    Admin
    Damyan Bogoev avatar
    581 posts

    Posted 13 Aug 2010 Link to this post

    Hello damian breland,

    I recommend you reading this blog post which explains how to solve the problem which you are facing.
    Hope that helps.

    Greetings,
    Damyan Bogoev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. damian breland
    damian breland avatar
    2 posts
    Member since:
    Sep 2009

    Posted 24 Aug 2010 Link to this post

    The issue ended up being related to Medium Trust.  Both old and new hosts seemed to have the same permissions, but obviously not.  Alexander @ Telerik very helpful - thanks. 

    All better now...

    Damian
Back to Top