OpenAccess ORM exception

Thread is closed for posting
2 posts, 0 answers
  1. Jason
    Jason avatar
    1 posts
    Member since:
    Apr 2009

    Posted 24 Mar 2012 Link to this post


    I have just installed the latest OpenAccess ORM in Visual Studio 2010 using the msi from your website but when I try to create a new OpenAccess project I get the following exception:

    Exception:  Failed to load Package 0d646c43-ced0-421b-8e65-b293e8bda85b. The package is either not installed or it is corrupted. The result is -2147467259.

    Generated by the method: Void LoadModelPackage(Microsoft.VisualStudio.Shell.Interop.IVsShell, System.Guid)

    Stack Trace:    at Telerik.OpenAccess.Sdk.Addin.VSAddin.VSHandler.LoadModelPackage(IVsShell vsShell, Guid guidPkg)
       at Telerik.OpenAccess.Sdk.Addin.VSAddin.VSHandler.LoadModelPackage(IServiceProvider serviceProvider, Guid guidPkg)
       at Telerik.OpenAccess.Sdk.Addin.VSAddin.VSHandler.ExecuteCommandFromDTE(OpenAccessAddin80 addin, Int32 commandId)
       at Telerik.OpenAccess.Sdk.Addin.VSAddin.VSHandler.UpgradeProjectReferences(MenuEntry entry)
       at Telerik.OpenAccess.Sdk.Addin.VSAddin.Menu.MenuOperations.ExecuteCommand(String cmd)
       at Telerik.OpenAccess.Sdk.Addin.VSAddin.OpenAccessAddin80.Exec(String longcommandName, vsCommandExecOption executeOption, Object& varIn, Object& varOut, Boolean& handled)

    Exception Type: System.Exception


    I have tried to reinstall/repair the component but I get the same error. Any ideas what is going wrong?
  2. Serge
    Serge avatar
    375 posts

    Posted 28 Mar 2012 Link to this post

    Hello Jason,

     Unfortunately I can't figure out what might be causing the error on package load. However there are a few things that can help us investigate this issue. Can you give us a bit more detail on your setup. This is in terms of Visual Studio version, OS etc. Also can you send us the Visual Studio log file, that would have a bit more information on exactly what went wrong.

    I am looking forward to resolving this issue. 

    Kind regards,
    the Telerik team
    Telerik OpenAccess ORM Q1 2012 release is here! Check out what's new or download a free trial >>
Back to Top