OA DSW will not start, +other problems

Thread is closed for posting
4 posts, 1 answers
  1. Alex
    Alex avatar
    141 posts
    Member since:
    Mar 2010

    Posted 07 Jun 2010 Link to this post

    When I open an OpenAccess solution (e.g. one of your samples) or if I try to open the DSW manually, I get an error message saying:

    *Edit the following error message comes up when opening your samples with the new OA*
    The Add-in 'Teleik OpenAccess DSW' failed to load causing an exception.... blah blah blah...
    ErrorMessage : <Unknown Error>
    Error number: 80131513

    *The error I get when opening the DSW in a new solution is just*
    The add-in supporting this command could not be loaded, do you wish to remove the command .....

    And in short, open access is not functional at the moment. (Where as in the previous version I had, it was working ok)
    (This all happened after I downloaded and installed Telerik_OpenAccess_ORM_2010_1_527_dev, and I have tried to uninstall and re-install it multiple times)

    Can anyone help me out?

    vs 1010 10.0.30319.1 RTMRel

    *Also I've seen on Stefen (Stephen?) Forte's demo at the user group meeting, how you could bring up the DSW graphical designer by going Add new item, but I do not seem to have any of the telerik open access items in my list (This is probably related to the above issues I'm having)
  2. Answer
    Jordan avatar
    547 posts

    Posted 10 Jun 2010 Link to this post

    Hi Alexander Sun,

    Regarding the OpenAccess item not showing in the "Add New Item" dialog, you must have in mind that such an item can only be added to a project that targets .net framework 3.5 or above. Please make sure that the items in this dialog are not filtered for an earlier version of the .net framework.

    Regarding the DSW issues that you mention, we have seen this in rare cases and only in a broken installation, for example:
    if you had a previous installation of the DSW and then installed the SP release that is the first one to include the DSW in the OpenAccess installer

    I would suggest that you do the following:
    1. when you try to invoke the DSW and visual studio suggests you to remove the commands you select to remove them
    2. uninstall OpenAccess ORM
    3. remove all DSW installations if you have any
    4. remove all Telerik OpenAccess assemblies from the GAC
    5. download the latest version of Telerik OpenAccess ORM (you must have in mind that the bits were updated a few days after the date that is shown) and install it

    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. DusterMynes
    DusterMynes avatar
    6 posts
    Member since:
    Dec 2010

    Posted 01 Dec 2010 Link to this post

    In my case I want to try the trial version and I have the same problems. The openAccess domain model doesn't show in the Vs.net add new item. But the only version I can download is the trial, so i'm stuck. Already try to uninstall everything, delete all the gac telerik dll and reinstall...but same results.
  4. Jordan
    Jordan avatar
    547 posts

    Posted 06 Dec 2010 Link to this post

    Hello Dom,

    The trial version of OpenAccess installs the same item templates as the dev / full version, so that should not be causing issues.
    If you already tried uninstalling and doing a fresh installation of the latest version of OpenAccess then this should not be an issue with registration of Visual Studio components.

    You must have in mind however, that the OpenAccess domain model item template is available only for projects that target .NET framework 3.5 and above.

    Do write back if the problem persists.

    Kind regards,
    the Telerik team
    Accelerate your learning with industry's first Telerik OpenAccess ORM SDK. Download today.
Back to Top