This is a migrated thread and some comments may be shown as answers.

NumericTextBox UI bug in Internet Explorer

2 Answers 44 Views
NumericTextBox
This is a migrated thread and some comments may be shown as answers.
This question is locked. New answers and comments are not allowed.
Julien
Top achievements
Rank 1
Julien asked on 12 Jan 2012, 04:16 PM
Hello,
I have a bug where if I disable a numeric textbox in Internet explorer, it seems I have two values over each other causing a "bold" effect. see screenshot and code below;

@(Html.Telerik().NumericTextBox()
    .Name(propertyName)
    .InputHtmlAttributes(new { style = "width:100%", id = Id, required= Required })
    .HtmlAttributes(new { style = "width:100%" })
    .EmptyMessage(EmptyMessage)
    .MinValue(MinValue)
    .MaxValue(MaxValue)
    .Value((double)Model)
    .Spinners(false)
    .Enable(!ReadOnly))  <--- ReadOnly is false

Any input appreciated, thanks.

2 Answers, 1 is accepted

Sort by
0
comgiu
Top achievements
Rank 2
answered on 02 Feb 2012, 03:10 PM
me too
0
Dimo
Telerik team
answered on 02 Feb 2012, 04:28 PM
Hello,

Please refer to the following forum thread for more information:

http://www.telerik.com/community/forums/aspnet-mvc/numericinput/calling-disable-in-a-javascript-client-side-causes-display-issue.aspx#1819343

Greetings,
Dimo
the Telerik team
If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the Telerik Extensions for ASP.MET MVC, subscribe to their blog feed now
Tags
NumericTextBox
Asked by
Julien
Top achievements
Rank 1
Answers by
comgiu
Top achievements
Rank 2
Dimo
Telerik team
Share this question
or