Not capturing...

35 posts, 0 answers
  1. Mario
    Mario avatar
    3 posts
    Member since:
    Aug 2019

    Posted 07 Aug in reply to Eric R | Technical Support Engineer Link to this post

    Hi Eric R,

    I post for help but didn't hear anything back. But here are the answers to your questions.

     

    1. Nothing is selected as far as Proxy Settings in the Network Settings area.

    2. Yes, .NET Core is installed. I'm on version 2.2.105

    3. The version of Mac I'm on is Mojave 10.14.6

     

    I hope this helps.

  2. Eleanor
    Eleanor avatar
    9 posts
    Member since:
    Aug 2019

    Posted 08 Aug in reply to Eric R | Technical Support Engineer Link to this post

    Hey, I'm not Alon, but I looked at default Network and the Web Proxy (HTTP) and Secure Web Proxy (HTTPS) checkboxes were not selected. I selected them, and when I opened Fiddler Everywhere, I was prompted for proxy password (used my registered fingerprint to allow), and the capture button started working (it prompted for proxy pw again first).
  3. Eleanor
    Eleanor avatar
    9 posts
    Member since:
    Aug 2019

    Posted 08 Aug in reply to Eleanor Link to this post

    Oh, and it would be nice if the documentation mentioned those settings were needed, even though they're not Fiddler settings!
  4. Eric R | Technical Support Engineer
    Admin
    Eric R | Technical Support Engineer avatar
    160 posts

    Posted 09 Aug Link to this post

    Hi Everyone,

    I tested this on macOS Mojave version 10.14.6. I opened up Fiddler Everywhere and verified the Web Proxy and Secure Web Proxy settings were checked. This happened automatically on start when I tested it.

    If this is not happening automatically when Fiddler Everywhere is opened, it is likely this setting has been unchecked. I recommend ensuring the Act as system proxy on startup is checked in the Fiddler Everywhere Settings. See the below screenshot for more details.



    If the issue persists, as a workaround, manually set the Web Proxy and Secure Web Proxy in macOS settings. System Preferences -> Network -> Advanced

    Please let me know if you need any additional information. Thank you.

    Regards,

    Eric R | Technical Support Engineer
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  5. Alon
    Alon avatar
    2 posts
    Member since:
    Aug 2019

    Posted 19 Aug in reply to Eric R | Technical Support Engineer Link to this post

    Hi Eric,
    Thank you for the response.
    1- Both checkboxes are NOT marked on both of my working network connections
    2- I wasn't sure so I install it anyway again.
    3- Mac OS: 10.14.6

    After installing the .Net Core I tried to open the 'Fiddler Everywhere' application again and I got an update popup to version 0.50.
    I installed it also and it still doesn't work.
    When I verified the latest workaround you suggested and set the Web Proxy (HTTP) and Secure Web Proxy (HTTPS) checkboxes manually with the 8866 port and Fiddler automatically started to capture the traffic.
    I can just indicate 2 issues after this was solved:
    1. The 'Capture' button is still not responding.
    2. The proxy checkboxes are not checked automatically when launching 'Fiddler'.

    Thank you for all of your assistance.
    Alon.
Back to Top