Not capturing...

52 posts, 0 answers
  1. Mario
    Mario avatar
    3 posts
    Member since:
    Aug 2019

    Posted 07 Aug in reply to Eric R | Technical Support Engineer Link to this post

    Hi Eric R,

    I post for help but didn't hear anything back. But here are the answers to your questions.

     

    1. Nothing is selected as far as Proxy Settings in the Network Settings area.

    2. Yes, .NET Core is installed. I'm on version 2.2.105

    3. The version of Mac I'm on is Mojave 10.14.6

     

    I hope this helps.

  2. Eleanor
    Eleanor avatar
    9 posts
    Member since:
    Aug 2019

    Posted 08 Aug in reply to Eric R | Technical Support Engineer Link to this post

    Hey, I'm not Alon, but I looked at default Network and the Web Proxy (HTTP) and Secure Web Proxy (HTTPS) checkboxes were not selected. I selected them, and when I opened Fiddler Everywhere, I was prompted for proxy password (used my registered fingerprint to allow), and the capture button started working (it prompted for proxy pw again first).
  3. Eleanor
    Eleanor avatar
    9 posts
    Member since:
    Aug 2019

    Posted 08 Aug in reply to Eleanor Link to this post

    Oh, and it would be nice if the documentation mentioned those settings were needed, even though they're not Fiddler settings!
  4. Eric R | Technical Support Engineer
    Admin
    Eric R | Technical Support Engineer avatar
    228 posts

    Posted 09 Aug Link to this post

    Hi Everyone,

    I tested this on macOS Mojave version 10.14.6. I opened up Fiddler Everywhere and verified the Web Proxy and Secure Web Proxy settings were checked. This happened automatically on start when I tested it.

    If this is not happening automatically when Fiddler Everywhere is opened, it is likely this setting has been unchecked. I recommend ensuring the Act as system proxy on startup is checked in the Fiddler Everywhere Settings. See the below screenshot for more details.



    If the issue persists, as a workaround, manually set the Web Proxy and Secure Web Proxy in macOS settings. System Preferences -> Network -> Advanced

    Please let me know if you need any additional information. Thank you.

    Regards,

    Eric R | Technical Support Engineer
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  5. Alon
    Alon avatar
    2 posts
    Member since:
    Aug 2019

    Posted 19 Aug in reply to Eric R | Technical Support Engineer Link to this post

    Hi Eric,
    Thank you for the response.
    1- Both checkboxes are NOT marked on both of my working network connections
    2- I wasn't sure so I install it anyway again.
    3- Mac OS: 10.14.6

    After installing the .Net Core I tried to open the 'Fiddler Everywhere' application again and I got an update popup to version 0.50.
    I installed it also and it still doesn't work.
    When I verified the latest workaround you suggested and set the Web Proxy (HTTP) and Secure Web Proxy (HTTPS) checkboxes manually with the 8866 port and Fiddler automatically started to capture the traffic.
    I can just indicate 2 issues after this was solved:
    1. The 'Capture' button is still not responding.
    2. The proxy checkboxes are not checked automatically when launching 'Fiddler'.

    Thank you for all of your assistance.
    Alon.
  6. Glenn
    Glenn avatar
    10 posts
    Member since:
    Oct 2019

    Posted 15 Oct Link to this post

    I'm having the same difficulties.  MacOS 10.14.6, running Fiddler 0.5.0.

    I tried installing mono ("brew install mono"), .NET ("brew cask install dotnet"), and then tried both Fiddler for OSX and Fiddler Everywhere.  Fidder for Mac never worked (too many mono errors), and while Fiddler Everywhere installed correctly, it never will capture anything.  Clicking on "Capture" does nothing, the button doesn't even appear to click / engage / change-color.

    Tried everything above, including rebooting my mac, reinstalling Fiddler, clearing out the certificate, etc.  Nothing works.

  7. Glenn
    Glenn avatar
    10 posts
    Member since:
    Oct 2019

    Posted 15 Oct in reply to Glenn Link to this post

    BTW, here's what I get if I run from within a terminal, as sudo:

    gstrycker@chi-gstryck-mac:~$ sudo /Applications/Progress\ Telerik\ Fiddler.app/Contents/MacOS/Progress\ Telerik\ Fiddler
    16:34:55.424 › [Product information] Progress Telerik Fiddler 0.5.0
    16:34:55.440 › [System information] Darwin chi-gstryck-mac 18.7.0 Darwin Kernel Version 18.7.0: Tue Aug 20 16:57:14 PDT 2019; root:xnu-4903.271.2~2/RELEASE_X86_64 x86_64
    16:34:55.497 › Initializing splash screen.
    2019-10-15 16:34:55.567 Progress Telerik Fiddler[5369:218466] *** WARNING: Textured window <AtomNSWindow: 0x7fd1cdc852f0> is getting an implicitly transparent titlebar. This will break when linking against newer SDKs. Use NSWindow's -titlebarAppearsTransparent=YES instead.
    16:34:55.591 › Attempting to run server - 5 attempts left.
    16:34:55.592 › Generating random port.
    16:34:55.592 › Trying to start server at port [34835].
    16:34:57.945 › Fetching .NET Core server status.
    16:34:58.488 › Application successfully connected to .NET Core server [34835].
    16:34:58.489 › Loading application in window.
    16:34:58.517 › Maximizing application window.
    16:34:58.625 › AutoUpdate is enabled.
    16:34:58.626 › Checking for update
    16:34:59.112 › Destroying splash screen.
    16:34:59.285 › Update for version 0.5.0 is not available (latest version: 0.5.0, downgrade is disallowed).
    16:35:20.012 › Closing server...
    16:35:26.123 › Server successfully closed.
    16:35:26.124 › Application exited with code 0.

     

  8. Eric R | Technical Support Engineer
    Admin
    Eric R | Technical Support Engineer avatar
    228 posts

    Posted 16 Oct Link to this post

    Hi Glenn,

    Thank you for providing the terminal output. Although, there isn't any indication of an error from the output. Is it possible to provide a screen recording of the behavior you're experiencing? If so, I ask that you record the following actions.

    1. Open Fiddler Everywhere

    2. Click the Capture/Capturing button

    3. Click the Settings Icon to open the Settings Dialog

    4. Click the HTTPS Tab

    5. Click the Connections Tab

    6. Click the Gateway Tab

    7. Close the Settings Dialog

    8. Hover over the Network Tab

    10. Open a terminal and run dotnet --info

    Once I have the above information, I will be able to provide a better response.

    Please let me know if this is possible. Thank you and I look forward to your reply.

    Regards,


    Eric R | Technical Support Engineer
    Progress Telerik

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  9. Glenn
    Glenn avatar
    10 posts
    Member since:
    Oct 2019

    Posted 16 Oct in reply to Eric R | Technical Support Engineer Link to this post

    I tried making a quicktime movie, but it's always above 2MB and the site won't let me update it.  Send me a personal email to glenn dot strycker at g-mail and I can send you the file.

    I'll try to attach screenshots here.  Note that I've tried other combinations for the settings as others have suggested on the thread, and all give the same conclusion (the "Capture" button will not click / change color / do anything).

    Also note that I tried several ports.... 8866 was the default I believe, I tried 8888 since that was what "Charles" uses and I got that to work, and I also tried 8060, too.  All of these resulted in the same behavior.

     

  10. Glenn
    Glenn avatar
    10 posts
    Member since:
    Oct 2019

    Posted 16 Oct in reply to Glenn Link to this post

    Try this link for the video:

    https://drive.google.com/open?id=1BwTx4Z2B3EuFzRWJdgCcpeKUo7EWzi09

  11. Eric R | Technical Support Engineer
    Admin
    Eric R | Technical Support Engineer avatar
    228 posts

    Posted 16 Oct Link to this post

    Hi Glenn,

    Thank you for the video. This was very helpful. I recommend selecting the Use system proxy (recommended) Radio Button in the Gateway settings. See the below screenshot for a visual reference.

    Please give this a try and let me know the results. Thank you and I look forward to your reply.

    Regards,


    Eric R | Technical Support Engineer
    Progress Telerik

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  12. Glenn
    Glenn avatar
    10 posts
    Member since:
    Oct 2019

    Posted 16 Oct Link to this post

    Tried that - no change.

    I think I've attempted most of the possible combinations for these check boxes and radio buttons.  Any particular ports I should try?

  13. Stephan
    Stephan avatar
    1 posts
    Member since:
    Oct 2019

    Posted 30 Oct Link to this post

    Hi.. I have the same issue where capture button does not do anything. Tried to re trust certificate as described.

     

    log:

    [2019-10-30 15:47:08:342] [info] [Product information] Progress Telerik Fiddler 0.5.0
    [2019-10-30 15:47:08:350] [info] [System information] Darwin bea-x1b.webdanmark.local 19.0.0 Darwin Kernel Version 19.0.0: Wed Sep 25 20:18:50 PDT 2019; root:xnu-6153.$
    [2019-10-30 15:47:08:474] [info] Initializing splash screen.
    [2019-10-30 15:47:08:523] [info] Attempting to run server - 5 attempts left.
    [2019-10-30 15:47:08:523] [info] Generating random port.
    [2019-10-30 15:47:08:523] [info] Trying to start server at port [9362].
    [2019-10-30 15:47:10:794] [info] Fetching .NET Core server status.
    [2019-10-30 15:47:11:228] [info] Application successfully connected to .NET Core server [9362].
    [2019-10-30 15:47:11:228] [info] Loading application in window.
    [2019-10-30 15:47:11:250] [info] Maximizing application window.
    [2019-10-30 15:47:11:357] [info] AutoUpdate is enabled.
    [2019-10-30 15:47:11:358] [info] Checking for update
    [2019-10-30 15:47:11:686] [info] Destroying splash screen.
    [2019-10-30 15:47:11:962] [info] Update for version 0.5.0 is not available (latest version: 0.5.0, downgrade is disallowed).
    [2019-10-30 15:52:16:487] [info] Closing server...
    [2019-10-30 15:52:22:600] [info] Server successfully closed.
    [2019-10-30 15:52:22:601] [info] Application exited with code 0.

    netcore:

    [2019-10-30 15:47:10:940] [Information] [Fiddler] !WARNING: Failed to get proxy information for Connection 'OSX Default' due to System.ArgumentOutOfRangeException Spec$
    Parameter name: i
    [2019-10-30 15:47:10:942] [Information] [Fiddler] !WARNING: The Default Gateway information could not be obtained.
    [2019-10-30 15:47:10:946] [Information] [Fiddler] Error: Failed to register Fiddler as the system proxy.
    [2019-10-30 15:49:40:868] [Information] [Fiddler] !WARNING: Failed to get proxy information for Connection 'OSX Default' due to System.ArgumentOutOfRangeException Spec$
    Parameter name: i
    [2019-10-30 15:49:40:868] [Information] [Fiddler] !WARNING: The Default Gateway information could not be obtained.
    [2019-10-30 15:49:40:868] [Information] [Fiddler] Error: Failed to register Fiddler as the system proxy.
    [2019-10-30 15:49:40:881] [Error] [Angular] Failed to toggle capturing
    [2019-10-30 15:49:49:593] [Information] [Fiddler] !WARNING: Failed to get proxy information for Connection 'OSX Default' due to System.ArgumentOutOfRangeException Spec$
    Parameter name: i
    [2019-10-30 15:49:49:593] [Information] [Fiddler] !WARNING: The Default Gateway information could not be obtained.
    [2019-10-30 15:49:49:593] [Information] [Fiddler] Error: Failed to register Fiddler as the system proxy.
    [2019-10-30 15:49:49:596] [Error] [Angular] Failed to toggle capturing
    [2019-10-30 15:49:50:417] [Information] [Fiddler] !WARNING: Failed to get proxy information for Connection 'OSX Default' due to System.ArgumentOutOfRangeException Spec$
    Parameter name: i
    [2019-10-30 15:49:50:417] [Information] [Fiddler] !WARNING: The Default Gateway information could not be obtained.
    [2019-10-30 15:49:50:417] [Information] [Fiddler] Error: Failed to register Fiddler as the system proxy.
    [2019-10-30 15:49:50:420] [Error] [Angular] Failed to toggle capturing
    [2019-10-30 15:49:59:766] [Information] [Fiddler] !WARNING: Failed to get proxy information for Connection 'OSX Default' due to System.ArgumentOutOfRangeException Spec$
    Parameter name: i
    [2019-10-30 15:49:59:766] [Information] [Fiddler] !WARNING: The Default Gateway information could not be obtained.
    [2019-10-30 15:49:59:766] [Information] [Fiddler] Error: Failed to register Fiddler as the system proxy.
    [2019-10-30 15:49:59:769] [Error] [Angular] Failed to toggle capturing
    [2019-10-30 15:50:00:123] [Information] [Fiddler] !WARNING: Failed to get proxy information for Connection 'OSX Default' due to System.ArgumentOutOfRangeException Spec$
    Parameter name: i
    [2019-10-30 15:50:00:123] [Information] [Fiddler] !WARNING: The Default Gateway information could not be obtained.
    [2019-10-30 15:50:00:123] [Information] [Fiddler] Error: Failed to register Fiddler as the system proxy.
    [2019-10-30 15:50:00:126] [Error] [Angular] Failed to toggle capturing
    [2019-10-30 15:50:00:273] [Information] [Fiddler] !WARNING: Failed to get proxy information for Connection 'OSX Default' due to System.ArgumentOutOfRangeException Spec$
    Parameter name: i
    [2019-10-30 15:50:00:273] [Information] [Fiddler] !WARNING: The Default Gateway information could not be obtained.
    [2019-10-30 15:50:00:273] [Information] [Fiddler] Error: Failed to register Fiddler as the system proxy.
    [2019-10-30 15:50:00:276] [Error] [Angular] Failed to toggle capturing
    [2019-10-30 15:50:00:446] [Information] [Fiddler] !WARNING: Failed to get proxy information for Connection 'OSX Default' due to System.ArgumentOutOfRangeException Spec$
    Parameter name: i
    [2019-10-30 15:50:00:446] [Information] [Fiddler] !WARNING: The Default Gateway information could not be obtained.
    [2019-10-30 15:50:00:446] [Information] [Fiddler] Error: Failed to register Fiddler as the system proxy.
    [2019-10-30 15:50:00:448] [Error] [Angular] Failed to toggle capturing
    [2019-10-30 15:50:00:608] [Information] [Fiddler] !WARNING: Failed to get proxy information for Connection 'OSX Default' due to System.ArgumentOutOfRangeException Spec$
    Parameter name: i
    [2019-10-30 15:50:00:608] [Information] [Fiddler] !WARNING: The Default Gateway information could not be obtained.
    [2019-10-30 15:50:00:608] [Information] [Fiddler] Error: Failed to register Fiddler as the system proxy.
    [2019-10-30 15:50:00:610] [Error] [Angular] Failed to toggle capturing
    [2019-10-30 15:50:00:777] [Information] [Fiddler] !WARNING: Failed to get proxy information for Connection 'OSX Default' due to System.ArgumentOutOfRangeException Spec$
    Parameter name: i
    [2019-10-30 15:50:00:777] [Information] [Fiddler] !WARNING: The Default Gateway information could not be obtained.
    [2019-10-30 15:50:00:777] [Information] [Fiddler] Error: Failed to register Fiddler as the system proxy.

     

  14. Eric R | Technical Support Engineer
    Admin
    Eric R | Technical Support Engineer avatar
    228 posts

    Posted 30 Oct Link to this post

    Hi Stephan,

    This appears to be something blocking Fiddler Everywhere from Registering as the System Proxy. I recommend opening up Fiddler Everywhere and then verifying the Proxy Settings a configured. See the below screenshots for what the Proxy Settings should be like when Fiddler Everywhere is running and not.

    Fiddler Everywhere Not Running

    Mac Proxy Settings when Fiddler Everywhere is not running.

    Fiddler Everywhere Running

    Mac proxy settings when Fiddler Everywhere is running.

    If the above behavior is not working as expected, I recommend checking the Web Proxy (HTTP) and Secure Web Proxy (HTTPS) items while Fiddler Everywhere is running and verifying that Capturing works.

    Please give this a try and let me know the results. Thank you and I look forward to your reply.

    Regards,


    Eric R | Technical Support Engineer
    Progress Telerik

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  15. Glenn
    Glenn avatar
    10 posts
    Member since:
    Oct 2019

    Posted 30 Oct in reply to Eric R | Technical Support Engineer Link to this post

    Whenever I change my Mac proxy settings and click "ok" and then "apply" in the Network dialog box, nothing happens, and when I go back into the Mac proxy settings the checkboxes are unmarked.

    This may be a Mac error and not Fiddler per se, but I cannot seem to get my Mac proxy changes to apply and persist.  Any ideas?

  16. Glenn
    Glenn avatar
    10 posts
    Member since:
    Oct 2019

    Posted 30 Oct in reply to Glenn Link to this post

    I think this is my issue here:  https://apple.stackexchange.com/questions/106742/mac-username-password-for-proxy-settings-keep-resetting-by-itself

    There may be a solution on this article, too, and it involves the system keychain instead of the user keychain.

  17. Glenn
    Glenn avatar
    10 posts
    Member since:
    Oct 2019

    Posted 30 Oct in reply to Glenn Link to this post

    One last observation... my Mac proxy settings dialog box looks different than Eric's screen capture above.  There are additional settings that I do not know how to fill.  What should be entered for the "proxy server" string fields?
  18. Glenn
    Glenn avatar
    10 posts
    Member since:
    Oct 2019

    Posted 30 Oct in reply to Glenn Link to this post

    screen shot
  19. Eric R | Technical Support Engineer
    Admin
    Eric R | Technical Support Engineer avatar
    228 posts

    Posted 30 Oct Link to this post

    Hi Glenn,

    I agree this is probably associated with the Mac configuration for changing the Proxy Settings. When I tested this in a local Mac environment, I had to provide my credentials when I started and shutdown Fiddler Everywhere. Although, I am not sure what would configuration would be set in order to bypass this.

    Additionally, this could be cause by an application as well which may be blocking any changes to the proxy. VPN and Firewall software commonly do this.

    As for the settings, the Auto Proxy Discovery is is usually for providing a .PAC file to configure the Proxy via a script. If you're not using that you can uncheck it.

    Please let me know if you need any additional information. Thank you.

    Regards,


    Eric R | Technical Support Engineer
    Progress Telerik

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  20. Dark
    Dark avatar
    3 posts
    Member since:
    Apr 2019

    Posted 25 Nov Link to this post

    Glenn,

    I had the same issues as what you are encountering.  What finally solved it for me was to perform the following steps:

    1. Open Fiddler Everywhere and disable the HTTPS setting (Uncheck the Decrypt HTTPS traffic in the HTTPS settings page)
    2. Close Fiddler
    3. Open your Mac user home directory (~) and delete the .fiddler (hidden) folder
    4. Open the advanced settings for the active network connection in the OS settings:
      1. System Preferences
      2. Network
      3. Select active network, then hit the Advanced button, open the Proxies tab
    5. Ensure the Web Proxy (HTTP) and the Secure Web Proxy (HTTPS) setting is checked and specify 127.0.0.1 for the web proxy server and 8866 for the port.  Close out of the OS settings.
    6. Open Fiddler, and hopefully you will get prompted for your password.

    If you don't get the password prompt, you might need to disable additional settings within Fiddler (example: Act as system proxy on startup) and then perform the steps above again before re-enabling the settings.

     

    NOTE: It seems as though Fiddler will start having issues when I log into a VPN (I'm using the Cisco AnyConnect software to remote into our work network).  And then it will start to have the above noted issues.  Also, it WILL NOT work if a VPN connection is active.  Is there any way to correct these issues? 

     

    Thanks

  21. Glenn
    Glenn avatar
    10 posts
    Member since:
    Oct 2019

    Posted 25 Nov in reply to Dark Link to this post

    @Dark, thank you, that totally worked!  Actually I wasn't even prompted for a password, the issue was that System Preferences / Network / Proxy / checkboxes wouldn't set and save without having the address and port specified.  Once I added those, I was able to save the preferences and apply them, so when I opened Fiddler it worked as expected.
  22. Eric R | Technical Support Engineer
    Admin
    Eric R | Technical Support Engineer avatar
    228 posts

    Posted 26 Nov Link to this post

    Hi Everyone,

    After reviewing more thoroughly, we have a Feedback Request Item for not seeing any records on a Mac. It appears that this might also have to do with using an Ethernet and a WiFi adapter. We are currently investigating different approaches for persisting System Proxy Settings on Mac.

    As a workaround, I recommend following the steps outlined by @Dark below.

    1. Open Fiddler Everywhere and disable the HTTPS setting (Uncheck the Decrypt HTTPS traffic in the HTTPS settings page)
    2. Close Fiddler
    3. Open your Mac user home directory (~) and delete the .fiddler (hidden) folder
    4. Open the advanced settings for the active network connection in the OS settings:
      1. System Preferences
      2. Network
      3. Select active network, then hit the Advanced button, open the Proxies tab
    5. Ensure the Web Proxy (HTTP) and the Secure Web Proxy (HTTPS) setting is checked and specify 127.0.0.1 for the web proxy server and 8866 for the port.  Close out of the OS settings.
    6. Open Fiddler, and hopefully you will get prompted for your password.

    As a token of gratitude for everyone's feedback, I have added a vote for each of you on this thread and encourage following to receive status updates. 

    Please stay tuned for any additional information in the Feedback Request. Thank you again for your patience and for using the Fiddler Forums.

    Regards,


    Eric R | Technical Support Engineer
    Progress Telerik

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top