Not able to build NativeScript App for iOS

2 posts, 0 answers
  1. Marc
    Marc avatar
    84 posts
    Member since:
    Oct 2013

    Posted 14 Nov 2016 Link to this post

    Hello,

    I am using the latest AppBuilder Windows client and thr latest AppBuilder CLI (3.5.2-771) and I am not able to build our NativeScript project for iOS, it only works for Android. I get the following log-output during build-time:

     

    Project "fanfiktion.tmp.proj" (default targets):
        ios Build Tooling revision 2016.11.02.1r
        Build Tooling Hostname administrators-mac-3.local
        Warning: npm
        Warning: WARN
        Warning: package.json @ No description
        Warning: npm
        Warning: WARN package.json
        Warning: @ No repository field.
        Warning: npm
        Warning: WARN package.json @ No README data
        Warning: npm
        Warning: WARN package.json @ No license field.
        Warning: Processing node_modules failed. Error: Command sandbox-pod failed with exit code 1
        Error: Build failed during execution
        Error: 'Build failed with error code 127'
    Done building project "fanfiktion.tmp.proj" -- FAILED.

     

    I am working with NativeScript 2.3.0. I know, that it is still in "Experimental" step, but I use this NativeScript version for some weeks now and I had no problems. In addition, I have uninstalled all the plugins, until there are just the tns-core-modules left. But the build still fails.

     

    Is there anything I can do?

     

    Regards

  2. Garo
    Admin
    Garo avatar
    136 posts

    Posted 15 Nov 2016 Link to this post

    Hi Marc,

    We were aware of this faulty behavior and I am glad to inform you that we provided a fix for it yesterday. You should be able to build successfully when using NativeScript 2.3.0. Please, let me know if this is not the case and you are still experiencing the issue.

    Regards,
    Garo
    Telerik by Progress
     

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

     
Back to Top