This is a migrated thread and some comments may be shown as answers.
Multi-Language supported?
3 Answers 12 Views
This is a migrated thread and some comments may be shown as answers.
Iros
Top achievements
Rank 1
Iros asked on 22 Aug 2016, 03:13 AM

When I try to use calendar to display Simple-Chinese, Traditional-Chinese, Korea... then it will cause JNI exception, please see attachments.

Is there any way to correct setting up calendar widget or it's not ready to support multi-language?

Thanks.

3 Answers, 1 is accepted

Sort by
0
Vladislav
Telerik team
answered on 24 Aug 2016, 10:07 AM
Hello Germos,

Thank you for contacting us.
Unfortunately we are unable to reproduce the described problem based on the information provided.
Is it possible to provide more info about your setup/project. A sample project (or just the relevant part of your original one) demonstrating the issue will be great.

Do you get this exception with other cultures (en, fr, etc.)?
What is the Android API version of the device/emulator where this exception is observed?
What is the exact version of our controls used?

Hopefully with this additional information we will be able to reproduce the problem.

Thank you in advance.

Regards,
Vladislav
Telerik by Progress
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
0
Iros
Top achievements
Rank 1
answered on 25 Aug 2016, 03:50 PM

I made a sample project, the sample result as shown on zipped file.

The language change to Traditional-Chinese will cause fail.
Change to english, french are ok.

It might be a UTF-8 or Unicode problem?

Pls see the complete project: https://docs.google.com/document/d/1lw9vbmf2ga_lRgNuJUavi7I2ch3yrnMINB5G61Qog6g/edit

 

Thank you

0
Vladislav
Telerik team
answered on 26 Aug 2016, 10:35 AM
Hi Germos,

Thank you for the additional information and sample project provided.
We were able to reproduce it locally, but we noticed that you are using outdated version of our controls (2016.2.708.230). We recently released a newer version (2016.3.822.231) which should be available under your account in the "Betas" section. And with this version (which targets the latest version of XamarinForms 2.3.1.114) the sample project works properly with these cultures.

Is it possible for you to try your project with the newer version of our controls?

Regards,
Vladislav
Telerik by Progress
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Asked by
Iros
Top achievements
Rank 1
Answers by
Vladislav
Telerik team
Iros
Top achievements
Rank 1
Share this question
or