Modifying Office Black Theme not working

6 posts, 0 answers
  1. Pierre
    Pierre avatar
    4 posts
    Member since:
    May 2011

    Posted 14 Oct 2011 Link to this post

    Hi,

        I modified the office black theme for the GridViewHeaderCell.xaml, followed the instructions in the document http://www.telerik.com/help/silverlight/common-styling-apperance-modifying-built-in-theme.html but the change wasn't reflected on the grid. I'm not sure what I'm doing wrong.
  2. Vanya Pavlova
    Admin
    Vanya Pavlova avatar
    2019 posts

    Posted 14 Oct 2011 Link to this post

    Hello Pierre,

     

    Can you verify whether you are creating a theme based on Office_Black or you are trying to modify the default style for a single GridViewHeaderCell? In case of a theme you may use a project from the following forum thread. If  you want to modify only that GridViewHeaderCell style you may use Expression Blend for that purpose. Furthermore you may also submit a new support ticket where you can attach your sample application. We may take a look at it and to provide you with an appropriate solution.   



    All the best,
    Vanya Pavlova
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  3. Pierre
    Pierre avatar
    4 posts
    Member since:
    May 2011

    Posted 14 Oct 2011 Link to this post

    Hi Vanya,

        I'd prefer to change the office_black theme..so that it affects all controls in the solution. Our company runs off of terminal server, so any animation is a killer. The app uses multiple grids and a dock control. The gridviewheadercell..when you mouseover there is a slight transition which I will have to remove and for the dock control the shade that happens when the tab is undocked.

    Thanks,

    Pierre
  4. Vanya Pavlova
    Admin
    Vanya Pavlova avatar
    2019 posts

    Posted 18 Oct 2011 Link to this post

    Hello Pierre,

     
    Thank you for getting back to us! When a single header cell goes into MoiseOver state a Border element named Background_Over appeared. You may remove it through deleting this Border and the animation which manipulates its Visibility. In our online docs we have an article which illustrates how to "Override the Default RadGridView Styles". The same is valid for every part of RadGridView. Regarding your question about RadDocking you should set the  telerik:AnimationManager.StyleSelector = null in RadDocking control and AnimationManager.IsGlobalAnimationEnabled=False. 
    Can you verify whether you still have problems with your theme project and the styles incorporated in it? 
    Keep in mind that you may always open a new support ticket where you can attach your sample application. We may take a look at it and in this way we would be able to provide you with an appropriate solution.

     



    Greetings,
    Vanya Pavlova
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  5. Pierre
    Pierre avatar
    4 posts
    Member since:
    May 2011

    Posted 19 Oct 2011 Link to this post

    Hi Vanya,

        here's what I have so far..I've re-Templated the HeaderCell that removes the mouseover for the header and it works..however I have a ToolTip in the HeaderCellStyle
    <Style x:Key="RegistrationStatusHeaderStyle" TargetType="telerik:GridViewHeaderCell">
                    <Setter Property="ToolTipService.ToolTip" Value="Registration Status" />
                </Style>

    so specifying the HeaderCellStyle reverts the templated header back to the default template. Is there anyway around this?
    Also...How do you set the styleselector to null? I tried to re-Template the compass so I could remove the shading when you dock a radpane on the RadDocking control but I was receiving an error Cannot create instance of Compass.

    Thanks
    Pierre
  6. Dani
    Admin
    Dani avatar
    848 posts

    Posted 24 Oct 2011 Link to this post

    Hello Pierre,

     
    Actually your should mark your HeaderCellStyle to be based on a particular theme:

    <Style x:Key="RegistrationStatusHeaderStyle" TargetType="telerik:GridViewHeaderCell" telerik:StyleManager.BasedOn="Your custom theme">
                    <Setter Property="ToolTipService.ToolTip" Value="Registration Status" />
                </Style>

    Here "Your custom theme" stands for the name of your theme. 

    To disable the AnimationManager for RadDocking, please set the needed AnimationManager properties on the RadDocking control as follows:
    <telerikDocking:RadDocking Margin="109,97,55,94" telerik:AnimationManager.AnimationSelector="{x:Null}" telerik:AnimationManager.IsAnimationEnabled="False">
                <telerikDocking:RadSplitContainer>
                    <telerikDocking:RadPaneGroup>
                        <telerikDocking:RadPane Header="Pane 1"/>
                        <telerikDocking:RadPane Header="Pane 2"/>
                    </telerikDocking:RadPaneGroup>
                </telerikDocking:RadSplitContainer>
            </telerikDocking:RadDocking>

    I hope this will be helpful.

    Best wishes,
    Dani
    the Telerik team
    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>
Back to Top