This is a migrated thread and some comments may be shown as answers.

Microsoft Visual Studio has detected that an operation is blocking user input.

9 Answers 908 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
This question is locked. New answers and comments are not allowed.
Rui
Top achievements
Rank 1
Rui asked on 27 Mar 2012, 11:27 AM

Hello, time to time when I use the designer with FluentCode my VS starts to be very slow and when I want to close it the following message comes up:


---------------------------
Microsoft Visual Studio
---------------------------
Microsoft Visual Studio has detected that an operation is blocking user input.  This can be caused by an active modal dialog or a task that needs to block user interaction.  Would you like to shut down anyway?
---------------------------
Yes   No   
---------------------------

9 Answers, 1 is accepted

Sort by
0
Zoran
Telerik team
answered on 30 Mar 2012, 09:03 AM
Hello Rui,

 Can you give us more information about the steps that you perform before seeing this message? What is the wizard that you used before seeing this message? We already have seen this problem and fixed in the case where it was showing after the Update Database From Model Wizard was executed. However we would like to know if there is such behavior present with another wizard different than the one mentioned.

The issue was related to having projects under source control which were not checked out prior to OpenAccess adding some new filed to those projects. We are looking forward to have more details from you on the situation.

All the best,
Zoran
the Telerik team
Telerik OpenAccess ORM Q1 2012 release is here! Check out what's new or download a free trial >>
0
Rui
Top achievements
Rank 1
answered on 03 Apr 2012, 11:08 PM
Well, I don't quite know. I remember I used the Database to Model and Model to Database. I'm using Fluent, hope it helps.
Now I'm not having anymore that problem since I'm not using it anymore.
0
Daniel
Top achievements
Rank 2
answered on 04 May 2012, 02:59 PM
I'm having the same issue. And yes it was after working with the OpenAccess Model. I can't close VS without this message appearing.
Microsoft Visual Studio has detected that an operation is blocking user input.  This can be caused by an active modal dialog or a task that needs to block user interaction.

This also affects the ability to CTRL-A or CTRL-C or any Visual Studio Shortcut
Any ideas on a fix? There is nothing open or loaded.. nothing in task list or processes.



0
Alexander
Telerik team
answered on 08 May 2012, 03:40 PM
Hello Daniel,

If possible, I suggest you to upgrade to the latest internal build of OpenAccess and if the problem remains, please try to remember what were your last actions that you performed before this error occurred. It would be helpful for us if you could tell us which was the last wizard that you used (for example Update Database or Update From Database) and whether any files in the project were added/modified as a result.

I am afraid that we will not be able to make any fixes in this area until we manage to reproduce the problem first, that is why we are asking for your cooperation. Thank you in advance.

Regards,
Alexander
the Telerik team
Follow @OpenAccessORM Twitter channel to get first the latest updates on new releases, tips and tricks and sneak peeks at our product labs!
0
Michael
Top achievements
Rank 1
answered on 22 Jun 2012, 03:58 PM
I got this well, but I remember exactly what happened. I was in the Telerik database modeling GUI, which were using for open access, and everytime I would update the model and save it, VS would give me a warning about not running something related to the process unless I knew where it cam from and trusted it. I guess this was because on save it would run something under the covers to generate the code.
Anyhow, after a while I selected the option to just let this happen without bugging me and the next time I did a save it did not bug me, unfortunately though the system started to immediately lock up the solution explorer an any other tabs grouped with it, as well as shortcut key.  The remainder of the GUI remains active.  Finally, when closing, I get the message above that everyone else is describing.

At a minumum, If i can figure out where to unset that "auto do it for me" setting, it may go back to working again.

-Michael
0
Alexander
Telerik team
answered on 27 Jun 2012, 12:50 PM
Hi Michael,

Those messages are indeed shown when the code generation is triggered. You can control them from the Tools -> Options -> Text Templating -> Show Security Message option.
So the problem on your side could be caused by those warnings or by the Update Model From Database wizard itself.
Thank you for your input, we will try this and hopefully it would help us reproduce the problem.

Greetings,
Alexander
the Telerik team
OpenAccess ORM Q2'12 Now Available! Get your hands on all the new stuff.
0
Gavin
Top achievements
Rank 1
answered on 22 Nov 2014, 07:11 PM
I am getting this error also.  Pretty easy to repro..  Load solution, open EntityModel designer.  build project.  Right click the model, Add Telerik Data Access service. Using Plain WCF service, Output to another solution project.  Compile the other project once wizard is complete.  At this point I can no longer type or use keyboard.  mouse works, but trying to delete text etc doesnt work.  If I close Studio I get:

---------------------------
Microsoft Visual Studio
---------------------------
Microsoft Visual Studio has detected that an operation is blocking user input.  This can be caused by an active modal dialog or a task that needs to block user interaction.  Would you like to shut down anyway?
---------------------------
Yes   No   
---------------------------

0
Viktor Zhivkov
Telerik team
answered on 26 Nov 2014, 03:15 PM
Hello Gavin,

Please excuse us for the inconvenience that you have experienced.
The issue you are describing is a known one and unfortunately currently there is no complete fix for it.
We have identified it to be linked to having any of the files that Add Telerik Data Access Service wizard will edit open in Visual Studio code editor. These files include any files generated previously using the same tool, app.config, web.config, Global.asax.cs/vb and any .CSV files. If you close all of them before running the wizard you should not experience the blocked user input.
If you are already experiencing the issue the only solution is to restart your Visual Studio instance.

I would like to ask you to give us a few mode details about your environment like:
  1. Version of Visual Studio using which you have witnessed the issue;
  2. Version of Telerik Data Access;
  3. Any files opened in Visual Studio code editor during the execution of the wizard.
Such information will help us identify any new scenarios where the issue is reproducing.

Regards,
Viktor Zhivkov
Telerik
 
OpenAccess ORM is now Telerik Data Access. For more information on the new names, please, check out the Telerik Product Map.
 
0
Robert
Top achievements
Rank 1
answered on 21 Jan 2016, 08:46 AM
Had the same issue. Had to disable the Add-In "Telerik Data Access" in VS.
Tags
General Discussions
Asked by
Rui
Top achievements
Rank 1
Answers by
Zoran
Telerik team
Rui
Top achievements
Rank 1
Daniel
Top achievements
Rank 2
Alexander
Telerik team
Michael
Top achievements
Rank 1
Gavin
Top achievements
Rank 1
Viktor Zhivkov
Telerik team
Robert
Top achievements
Rank 1
Share this question
or