Logarithmic Scale == Inifinite Loop...

5 posts, 0 answers
  1. RoadWarrior
    RoadWarrior avatar
    45 posts
    Member since:
    Jan 2010

    Posted 04 Jun 2010 Link to this post

    There is an issue with the new IsLogarithmic scale property.  When a DataPoint in a series contains a YValue of "0" is added to the chart, the entire browser process will lockup.  Usually have to kill the browser.  Please advise on a workaround or fix.
  2. Vladimir Milev
    Admin
    Vladimir Milev avatar
    1061 posts

    Posted 10 Jun 2010 Link to this post

    Hi RoadWarrior,

    Thanks for reporting this issue. We have confirmed it to be a bug. Unfortunately we can't offer any good work-arounds except trying to approximate the value to something very close to zero like 0.001 and override the label with custom text "0".

    Best wishes,
    Vladimir Milev
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. Vladimir Milev
    Admin
    Vladimir Milev avatar
    1061 posts

    Posted 10 Jun 2010 Link to this post

    Hi RoadWarrior,

    Also I forgot to mention your telerik points have been updated for reporting the bug. Thanks again!

    Best wishes,
    Vladimir Milev
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  4. RoadWarrior
    RoadWarrior avatar
    45 posts
    Member since:
    Jan 2010

    Posted 10 Jun 2010 Link to this post

    Thanks for the idea.  However, I tried the 0.001 approach, but it leads to an unexpectedly skewed graph (see attached image).
  5. Vladimir Milev
    Admin
    Vladimir Milev avatar
    1061 posts

    Posted 15 Jun 2010 Link to this post

    Hello RoadWarrior,

    Unfortunately I didn't think of this side effect :-(. I am afraid you will have to wait for the next of the latest internal builds to have this issue resolved. The fix is already checked-in and it should appear soon.

    Kind regards,
    Vladimir Milev
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
Back to Top