LocalFileSystem not getting loaded/not found

Thread is closed for posting
4 posts, 0 answers
  1. Greg
    Greg avatar
    11 posts
    Member since:
    Mar 2012

    Posted 20 Aug 2012 Link to this post

    I am trying to use the phonegap File Api, and it appears that the proper JS are not getting loaded. Not sure if it is a Chrome or Mist issue.

    Uncaught ReferenceError: LocalFileSystem is not defined

    To replicate and test, I just used your example in the File documentation. I just took the example code and put it into the index.html file of a new Kendo UI project.


    I am currently testing with Chrome version 22.0.1229.8 dev. I have not tested on anything other than Chrome. I will test tomorrow in another browser if I have a chance. 

    I am just referencing the Cordova file set with this, is that all I need to do?? Appears so.
    <script type="text/javascript" charset="utf-8" src="cordova.js"></script>

  2. Greg
    Greg avatar
    11 posts
    Member since:
    Mar 2012

    Posted 21 Aug 2012 Link to this post

    Can't test in other browsers cause they aren't supported, but I also tried in Canary and it still didn't work. Same error where "LocalFileSystem" was not defined.
    Version 23.0.1240.0 canary
  3. Nikolay
    Nikolay avatar
    1 posts
    Member since:
    Aug 2012

    Posted 28 Aug 2012 Link to this post

    Hi Greg,

    Thank you for reporting this issue.
    It's logged.

    The thing that's worth to mention, though, is that we can't emulate the functionality. We will mock the API, so no errors are thrown and perhaps we can mock a single file in order to have some testing value in the simulator, but that is as far as we can go in such environment.

    I hope you are enjoying our product.
    Stay tuned, we are cooking some great stuff for the next release.

    Nikolay Tsenkov
  4. Nos
    Nos avatar
    1 posts
    Member since:
    Nov 2012

    Posted 15 Nov 2012 Link to this post

    This is the only issue I've run into after importing a whole Cordova/jQM project into Icenium. It's good to know it's being worked on.

    I'll see if Graphite doesn't have this issue as soon as I can get a sysadmin to install it on my machine.
Back to Top