LoadContentFrom not calling my controller

2 posts, 0 answers
  1. Alden
    Alden avatar
    22 posts
    Member since:
    Aug 2011

    Posted 03 May 2013 Link to this post

    Hi, I've begun the process of upgrading my MVC Telerik Extension app to Kendo.  I am on MVC4 using the server wrappers.  It didn't take long before I ran into a perplexing issue.
    The first thing I did was upgrade the menu to this:
    @( Html.Kendo().Menu()
        .Items(menu =>
            menu.Add().Text("Tasks").Action("Index", "Tasks");
           @* Rest eliminated *@
    And I get JS error jQuery(...).kendoMenu is not a function in the browser on this code:
    On that same page is a tabstrip here:
    @( Html.Kendo().TabStrip()
        .Items(parent =>
                .Text("My Tasks")
                .LoadContentFrom("MyTasks", "Tasks");
            @* Abbreviated *@
    But this never calls my MyTasks controller.  This all worked fine with the Extensions, so I must have a configuration issue, right?  What am I doing wrong?

  2. Petur Subev
    Petur Subev avatar
    1882 posts

    Posted 07 May 2013 Link to this post

    Hello Alden,

    Make sure you checked the troubleshooting guide:


    Also in the process of updating the following topic (and the other subtopics in the TreeView on the left for the different widgets) should be of help:


    Kind Regards,
    Petur Subev
    the Telerik team
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
Back to Top