This is a migrated thread and some comments may be shown as answers.

KendoUI Jsp wrapper Beta

0 Answers 15 Views
Miscellaneous
This is a migrated thread and some comments may be shown as answers.
Adebayo
Top achievements
Rank 1
Adebayo asked on 23 Apr 2015, 11:06 PM

I need a quick help here , i followed the tutorials  online on using kendo ui jsp wrapper to do crud operation , where i have problem is when editting with popup  when i click the update and send the request to my servlet , all my request.getParamere() are returning null values , a quick check on the brower developer shows that datas where actually sent seen scrren shot below 

 

and my page looks like this 

<%-- 
    Document   : firstpage
    Created on : Apr 16, 2015, 3:17:28 PM
    Author     : Adebayo
--%>
<%@taglib prefix="kendo" uri="http://www.kendoui.com/jsp/tags"%>
<%@page import="com.google.gson.Gson"%>
<!DOCTYPE html>
<html>
<head>
  <meta http-equiv="Content-Type" content="text/html; charset=US-ASCII">
  <title>Insert title here</title>

  <link href="styles/kendo.common.min.css" rel="stylesheet">
  <link href="styles/kendo.default.min.css" rel="stylesheet">

  <script src="js/jquery.min.js"></script>
  <script src="js/kendo.all.min.js"></script>
</head>
<body>

  <!-- products grid will go here -->
<kendo:grid name="products" pageable="true"  sortable="true" filterable="true" groupable="true">
  <kendo:grid-pageable pageSizes="true" refresh="true" buttonCount="5"/>
    <kendo:grid-editable mode="popup"/> 
                         
    <kendo:grid-toolbar>
  <kendo:grid-toolbarItem name="create" />
</kendo:grid-toolbar>
    <kendo:dataSource pageSize="10">
 
  <kendo:dataSource-transport>
  <kendo:dataSource-transport-read url="employeeJson" type="GET"></kendo:dataSource-transport-read>
  <kendo:dataSource-transport-update url="employeeJson?update" type="POST"></kendo:dataSource-transport-update>
  <kendo:dataSource-transport-create url="getEmployees?create" type="POST"></kendo:dataSource-transport-create>
  <kendo:dataSource-transport-destroy url="getEmployees?delete" type="POST"></kendo:dataSource-transport-destroy>
     
</kendo:dataSource-transport>


 
        
    <kendo:dataSource-schema >
 
<kendo:dataSource-schema-model id="ref_id">
    
    
     
<kendo:dataSource-schema-model-fields>
    
     <kendo:dataSource-schema-model-field name="Employees">
      <kendo:dataSource-schema-model-field-validation required="true"/>
   </kendo:dataSource-schema-model-field>
<kendo:dataSource-schema-model-field name="ref_id" type="string" />
<kendo:dataSource-schema-model-field name="passport_no" type="string" />
<kendo:dataSource-schema-model-field name="surname" type="string" />
<kendo:dataSource-schema-model-field name="dob" type="date" />
<kendo:dataSource-schema-model-field name="cre_date" type="date" />
<kendo:dataSource-schema-model-field name="enrol_no" type="string" />
 
</kendo:dataSource-schema-model-fields>
</kendo:dataSource-schema-model>
</kendo:dataSource-schema>
      
    </kendo:dataSource>
    
    <kendo:grid-columns>
        
      <kendo:grid-column title="Refrence No" field="ref_id" />
      <kendo:grid-column title="Passport No" field="passport_no"/>
      <kendo:grid-column title="Surname" field="surname" />
      <kendo:grid-column title="Date Of Birth" field="dob"  format="{0:dd-MMM-yyyy}"/>
      <kendo:grid-column title="Create Date" field="cre_date" format="{0:dd-MMM-yyyy}" />
      <kendo:grid-column title="Enroment No" field="enrol_no"/>
      
       <kendo:grid-column>
    <kendo:grid-column-command>
      <kendo:grid-column-commandItem name="edit"></kendo:grid-column-commandItem>
      <kendo:grid-column-commandItem name="destroy"></kendo:grid-column-commandItem>
    </kendo:grid-column-command>
  </kendo:grid-column>
    </kendo:grid-columns>
    
  </kendo:grid>
</body>
</html>

What im i doing wrong ?

No answers yet. Maybe you can help?

Tags
Miscellaneous
Asked by
Adebayo
Top achievements
Rank 1
Share this question
or