This is a migrated thread and some comments may be shown as answers.

Issue with Silverlight RadControls and Safari 5.1

12 Answers 84 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Eric
Top achievements
Rank 1
Eric asked on 20 Sep 2011, 03:43 PM

We are experiencing an issue with our Silverlight application that has the Telerik Silverlight RadControls in Safari 5.1. The application loads and performs normal but if you navigate from our application to another site that does not have Silverlight you will get a Windows application error with the WebKit2WeProcess.exe.

We are also able to get this error just by navigating to http://demos.telerik.com/silverlight/ and then to http://www.google.com/ so it does not seem to be an issue with just our application. However we are not able to reproduce the error if we navigate from a Silverlight application that does not have the Telerik RadControls to another site without Silverlight.

This issue appears on Windows XP and Windows 7 computers when running Safari 5.1. This does not appear to be an issue with other browsers (IE, FireFox and Chrome) on those same computers.

Please let me know if you need additional information or if there is a known workaround for this issue.

12 Answers, 1 is accepted

Sort by
0
Boyan
Telerik team
answered on 22 Sep 2011, 01:36 PM
Hi Eric,

This is a very strange issue and we are not aware of it. I tested this on my Windows7 machine and  Safari 5.1 but was not able to reproduce the issue. No error was thrown and the WebKit2WeProcess.exe was still running. Does this happens only with specific Telerik controls or with all?

All the best,
Boyan
the Telerik team

Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

0
Eric
Top achievements
Rank 1
answered on 22 Sep 2011, 07:17 PM

The issue seems to happen when any Telerik Silverlight control is loaded. This appears to be similar to the problem reported in another forum post because of the response below that alludes to there being issues with the Silverlight module in Safari 5.1:
 
"We are aware of that issue, it came with the latest version of Safari (5.1), which was released after release. It seems that in the latest version of Safari there is a huge issue with the Silverlight module, which is used by RadAsyncUpload. As a temporary solution I would suggest to disable Silverlight, until we find out what is going wrong." (http://www.telerik.com/community/forums/aspnet-ajax/async-upload/asyncupload-handler-exeption.aspx)

Both the Windows 7 and XP computers have Silverlight version 4.0.60531.0.

The Windows 7 error has the following details:

Problem Event Name: BEX

Application Name: WebKit2WebProcess.exe

Application Version: 7534.50.0.1

Application Timestamp: 4e056f84

Fault Module Name: unknown

Fault Module Version: 0.0.0.0

Fault Module Timestamp: 00000000

Exception Offset: 7eaf5340

Exception Code: c0000005

Exception Data: 00000008

OS Version: 6.1.7601.2.1.0.256.48

Locale ID: 1033



The Windows XP error has the following details:
First we get a Data Execution Prevention message with the following:
"To help protect your computer, Windows has closed this program.
Name: WebKit2WebProcess.exe
Publisher: Apple Inc."

After closing that message we then get the following Windows exception:
Error signature:

EventType : BEX P1 : WebKit2WebProcess.exe P2 : 7534.50.0.1

P3 : 4e056f84 P4 : unknown P5 : 0.0.0.0 P6 : 00000000

P7 : 7fc85580 P8 : c0000005 P9 : 00000008 

Please let me know if you need any additional information.
 

0
Boyan
Telerik team
answered on 28 Sep 2011, 10:10 AM
Hello Eric,

Thank you for the additional information but we are still not able to reproduce the issue using Windows 7 and  Silverlight version 4.0.60531.0. Do you have some kind of add-ons installed that may cause the issue. If yes, uninstall them and try if this will fix the problem. I made a small search over the Safari forums and as far as I see the new version of Safari have some problems with crashing  WebKit2WebProcess.exe, however none of them was related with Silverlight. We are not doing anything browser specific in our code, so it is very strange that just our controls cause this crash. The problem is that without reproducing the problem at our side we can't tell what is going wrong.

Greetings,
Boyan
the Telerik team

Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

0
Eric
Top achievements
Rank 1
answered on 14 Nov 2011, 07:10 PM

The install for Safari is all the defaults with no non-standard add-ons. I tried with the latest 5.1.1 and the issue is still apparent. However, since Safari on Windows is not a supported OS browser combination (per the system requirements tab http://www.microsoft.com/getsilverlight/get-started/install/default.aspx) we have decided to not pursue this issue further.

0
phong
Top achievements
Rank 1
answered on 26 Oct 2012, 10:49 AM
Hi telerik,
I also see the same problem with Eric about the error loading telerik silverlight control on safari brower.
But I dont't see you confirm that it is not working in safari.
Because I find in a help of telerik is:
http://www.telerik.com/help/silverlight/installation-system-requirements.html
And I also see in some the link that the Telerik is not support on Safari because this is not brower of Window. I want to know, this bug is fixed in versions of silverlight 4 and silverlight 5.
And if can, I want to know how to install to telerik silverlight control work fine in safari.
Currently, These are the versions I am using:
    Telerik: 
        - runtime version: v2.0.50727
        - version: 2012.2.607.35
    Silver light4:
        - runtime version:v2.0.50727
        - version: 2.0.5.0
And It is working fine in IE 9, Chrome , Firefox 12.0, but It is not working on safari 5.17.

Thanks,

Phong Nguyen
0
Boyan
Telerik team
answered on 31 Oct 2012, 02:56 PM
Hi phong,

Currently we do not support Safari for Windows as we are having some problems that we can't resolve due to framework limitations. However our controls should be working fine for Safari browser for MAC.

Regards,
Boyan
the Telerik team

Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

0
Thomas
Top achievements
Rank 1
answered on 05 Nov 2012, 03:57 AM
Hi Boyan,

The confirm answer is good for me. Thank you very much.

Regards,

Phong Nguyen
0
KocSchool
Top achievements
Rank 2
answered on 08 May 2013, 07:37 AM
Hi Boyan;

Can I ask a question to you? In Silverlight application, links that does not run in safari on mac. Is it silverlight 
bug? 

Thanks,
Murat Ba┼čeren
0
Tina Stancheva
Telerik team
answered on 10 May 2013, 01:27 PM
Hello Murat,

Unfortunately I'm not sure what is causing this issue. But if you can elaborate on your scenario and its implementation further, we can take a closer look at what is causing it.

Regards,
Tina Stancheva
the Telerik team

Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

0
Tom
Top achievements
Rank 1
answered on 23 Jun 2018, 05:07 PM
I am currently using a Windows XP operating system. So when I am running the latest version of Safari(5.1), but also this issues always happen to me.aactually mainly there is a problem with the Silverlight apps when I am trying to steer to the other websites that do not contain Silverlight apps. So this is a big problem and I have also tried to take help from <a href="https://microsoftsupport.co/microsoft-support-canada">Microsoft tech support canada</a> and to know the solution. So it would be possible to know the solution to this problem properly??
0
Tom
Top achievements
Rank 1
answered on 23 Jun 2018, 05:09 PM
I am currently using a Windows XP operating system. So when I am running the latest version of Safari(5.1), but also this issues always happen to me.aactually mainly there is a problem with the Silverlight apps when I am trying to steer to the other websites that do not contain Silverlight apps. So this is a big problem and I have also tried to take help from https://microsoftsupport.co/microsoft-support-canada and to know the solution. So it would be possible to know the solution to this problem properly??
0
Tom
Top achievements
Rank 1
answered on 23 Jun 2018, 05:11 PM
I am currently using a Windows XP operating system. So when I am running the latest version of Safari(5.1), but also this issues always happen to me.aactually mainly there is a problem with the Silverlight apps when I am trying to steer to the other websites that do not contain Silverlight apps. So this is a big problem and I have also tried to take help from[url="https://microsoftsupport.co/microsoft-support-canada"]Microsoft Support Canada[/url] and to know the solution. So it would be possible to know the solution to this problem properly??
Tags
General Discussions
Asked by
Eric
Top achievements
Rank 1
Answers by
Boyan
Telerik team
Eric
Top achievements
Rank 1
phong
Top achievements
Rank 1
Thomas
Top achievements
Rank 1
KocSchool
Top achievements
Rank 2
Tina Stancheva
Telerik team
Tom
Top achievements
Rank 1
Share this question
or