This is a migrated thread and some comments may be shown as answers.

Issue: Sales Dashboard Demo - OpenAccess 2010.3 1125

2 Answers 40 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
This question is locked. New answers and comments are not allowed.
Dennis Perlot
Top achievements
Rank 1
Dennis Perlot asked on 28 Feb 2011, 02:56 PM
Hi,

I downloaded and tried to run locally the Sales Dashboard Demo (ASPX.NET AJAX + OpenAccess) and I experienced some issues with OpenAccess. I installed the current latest version (2010.3 1125) and I got into some issues - You can see this post for additional info: http://www.telerik.com/community/forums/aspnet-ajax/general-discussions/sales-dashboard-assemblies-problem.aspx

It seems to be some issue with the current version 2010.3 1125.
I uninstalled this latest version (from disk and GAC), I clean installed the previous version 2010.3.1110 and it worked fine.

I didn't get the error anymore:
"Could not load file or assembly 'Telerik.OpenAccess, Version=2010.3.1110.3, Culture=neutral, PublicKeyToken=7ce17eeaf1d59342' or one of its dependencies. The system cannot find the file specified."
 
Still, I would like to understand what is the issue with the latest version since I would like to use it.

Any thoughts ??

Thanks,
Nuno Senica

2 Answers, 1 is accepted

Sort by
0
Alexander
Telerik team
answered on 03 Mar 2011, 03:33 PM
Hi Dennis Perlot,

The problem is that the demo is referencing the assemblies with version 2010.3.1110 from the Binaries/OpenAccess folder but the enhancer from the version installed on your machine is used. The enhancer is a special tool that OpenAccess uses to inject some specific code in the assembly as a post build step and it is not possible to use OpenAccess assemblies and enhancer with different versions.

The solution would be to install the OpenAccess version you would like to use and delete the Binaries/OpenAccess folder from the project. Then fix the invalid references, so that they point to the OpenAccess assemblies installed in the GAC, and rebuild the solution. I hope that will fix the problem.

Greetings,
Alexander
the Telerik team
Registration for Q1 2011 What’s New Webinar Week is now open. Mark your calendar for the week starting March 21st and book your seat for a walk through all the exciting stuff we ship with the new release!
0
Nuno
Top achievements
Rank 1
answered on 03 Mar 2011, 07:46 PM

Hi Alexander,

I answered to your post in the other thread:
http://www.telerik.com/community/forums/aspnet-ajax/general-discussions/sales-dashboard-assemblies-problem.aspx

Please take a look at it and give me your thoughts.

Thank you,
Nuno Senica

Tags
General Discussions
Asked by
Dennis Perlot
Top achievements
Rank 1
Answers by
Alexander
Telerik team
Nuno
Top achievements
Rank 1
Share this question
or