IsInEditMode calls EditStarted event sometime and sometimes not.

2 posts, 0 answers
  1. Latha
    Latha avatar
    1 posts
    Member since:
    Dec 2012

    Posted 16 Dec 2012 Link to this post

    Hi Team

    The below code is used in IsInEditMode. I tried to replicate the scenario that when the EditStarted event is fired and not fired.
    After launching the tree view, when i try to edit the node. I am able to edit the node. After expanding the node.the node can not be edited. That time EditStarted event event is not fired. During the expanding, web service call is done to bind the child items for that node. Can you provide your comments. The current verion of control is 2011.2.712.1040

     public bool IsInEditMode
                get { return isInEditMode; }
                    if (this.isInEditMode != value)
                        isInEditMode = value;

  2. Pavel R. Pavlov
    Pavel R. Pavlov avatar
    1237 posts

    Posted 19 Dec 2012 Link to this post

    Hello Latha,

    I tried to reproduce your issue with our latest release but it seems that the code works as expected. Can you please take a look at the attached project and check if I have missed something? Also please make sure you're using our latest dlls in order to take advantage of our latest fixes and features.

    Pavel R. Pavlov
    the Telerik team

    Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

Back to Top