Invalid Certificates - doesn't Telerik like my certs?

6 posts, 0 answers
  1. Jonathan
    Jonathan avatar
    10 posts
    Member since:
    Jan 2014

    Posted 14 Dec 2016 Link to this post

    Hi..

    I'm using VS.  Trying build iOS, App package in Cloud.

    In the build window 'Select Provision'  I get Invalid Certificates.

    I have a provision file, and cert loaded. Created from my Apple Dev account.  The same files work in XCODE!!!

    Why doesn't telerik like my certs?

    See screenshot

    thanks inadvance.

  2. Tsvetina
    Admin
    Tsvetina avatar
    2087 posts

    Posted 15 Dec 2016 Link to this post

    Hi Jonathan,

    It seems like your scenario falls under point 4: The certificate that you used to create your provisioning profile is not imported in Telerik Platform from this KB article:

    Unable to Select Provisioning Profile for iOS App Build

    If the certificate is grayed out, this means that you have not imported it into Telerik Platform. Locate and import the certificate and you should be able to build.

    Regards,
    Tsvetina
    Telerik by Progress
     

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

     
  3. Jonathan
    Jonathan avatar
    10 posts
    Member since:
    Jan 2014

    Posted 15 Dec 2016 in reply to Tsvetina Link to this post

    Hi..

    The cert appears in the box - with the correct info. It's looks grayed out

    I removed the info in my screenshot.

    The certificate is new.. and I tried several other that all work in Xcode.

     

    any ideas

  4. Tsvetina
    Admin
    Tsvetina avatar
    2087 posts

    Posted 15 Dec 2016 Link to this post

    Hello Jonathan,

    The certificate name is visible, because the provisioning profile is referencing it. This doesn't mean that the certificate is imported in AppBuilder. As the KB article says, if the certificate is grayed out, this means that you have not imported it into Telerik Platform. Here is a screen shot that shows how a build window looks when I delete my certificate and try to build an app.

    Verify that the certificate referenced by your provisioning profile is imported in AppBuilder, by checking for it in AppBuilder->Options->Mobile->Cryptographic Identities.


    Regards,
    Tsvetina
    Telerik by Progress
     

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

     
  5. Jonathan
    Jonathan avatar
    10 posts
    Member since:
    Jan 2014

    Posted 15 Dec 2016 in reply to Tsvetina Link to this post

    Hi..

    I know have it loade.  'Valid Certificates' 

    But the build button is grayed out.  The App IDs also match.

    Any ideas?

     

    thanks again

     

  6. Tsvetina
    Admin
    Tsvetina avatar
    2087 posts

    Posted 19 Dec 2016 Link to this post

    Hi Jonathan,

    Without looking at your certificate and provisioning profile, we are unable to tell what is wrong, apart from suggesting the usual reasons for such behavior. The fastest way to resolve the issue would be if you open a support ticket and send us your provisioning profile and certificate (in P12 format, password included), so we can test them locally.

    In the meantime, my suggestion would be to also check the expiry date of the certificate (again a suggestion from the KB article I previously linked to):
    1. Go to AppBuilder -> Options -> Mobile -> iOS -> Cryptographic Identities.
    2. Locate the certificate that corresponds to the provisioning profile that you are trying to use.
    3. Check the certificate expiry date.


    Regards,
    Tsvetina
    Telerik by Progress
     

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

     
Back to Top