This is a migrated thread and some comments may be shown as answers.

Icons not displaying

4 Answers 1055 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Brian
Top achievements
Rank 1
Brian asked on 11 Jan 2013, 05:15 PM
When I run my app on localhost for testing, the icons all show properly.  When I deploy my app in IIS, I don't get any icons either in a desktop browser or from a mobile device.  The Content folder is there in the deployment, it all looks fine.  What am I missing?

4 Answers, 1 is accepted

Sort by
0
Kamen Bundev
Telerik team
answered on 14 Jan 2013, 07:49 AM
Hi Brian,

Your web server probably doesn't know how to serve the icons. We prepared an article on this topic, but currently it is not available in the online documentation, you can check it out in the docs master branch. Let me know if it helps.

All the best,
Kamen Bundev
the Telerik team
Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
0
Brian
Top achievements
Rank 1
answered on 14 Jan 2013, 02:36 PM
Yes, that was helpful.  I made the change in the web.config from the article and re-deployed.  It still did not work.  I checked for the font files in the deployment and they were not there.  I manually copied them into the deployment folders and the icons then showed in the browsers from both desktop and the mobile device.  However, now every time I test and re-deploy, those two files are deleted and I have to manually copy them into the deployment again.  It would be nice if the Deployment package included those files automatically.  Is there an easy way to tell the build package to include them?
0
Kamen Bundev
Telerik team
answered on 14 Jan 2013, 03:25 PM
Hi Brian,

Can you check if this thread on StackOverflow can help?

All the best,
Kamen Bundev
the Telerik team
Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
0
Brian
Top achievements
Rank 1
answered on 14 Jan 2013, 04:08 PM
Yes, setting the Build Action to Content for those two files includes them in the build package and they get deployed.  Adding that bit of info to your doc with the IIS web.config info would have really helped.  That stackoverflow link also described a permanent solution to including those kinds of files for the future.  Though I did not implement that, it's nice to know it's there.  Thanks for the help.
Tags
General Discussions
Asked by
Brian
Top achievements
Rank 1
Answers by
Kamen Bundev
Telerik team
Brian
Top achievements
Rank 1
Share this question
or