How to open http:// link outside app in any native OS browser -

3 posts, 1 answers
  1. Markus
    Markus avatar
    205 posts
    Member since:
    Nov 2005

    Posted 03 Dec 2013 Link to this post

    I have an app that will display some links.

    Now when clicked the links open in the app -> so there is no way back :-(

    This is what I have tried without luck.

    Any help on that? Using Icenium 1.9 with cordova 3. 

                      <a href="'#=Homepage#','_blank','location=yes');" target="_blank">#=Gemeinde#</a><br /><br /><br />
                      Homepage 2
                      <a href="#=Homepage#"    data-rel="external" >#=Gemeinde#</a><br /><br /><br />
                      Homepage 3
                      <a href="#=Homepage#"    data-rel="external" target="_blank" >#=Gemeinde#</a><br /><br /><br />
                      Homepage 4
                      <a href="#=Homepage#"    data-rel="external" target="_system" >#=Gemeinde#</a><br /><br /><br />
                      Homepage 5
                      <a href="#=Homepage#"   target="_system" >#=Gemeinde#</a><br /><br /><br />
                      Homepage 6
                      <a  onclick="'#=Homepage#', '_system');"> #=Gemeinde#</a><br /><br />

  2. Answer
    Zdravko avatar
    657 posts

    Posted 04 Dec 2013 Link to this post

    Hi Markus,

    You can open an external link via InAppBrowser by setting the target value to '_blank'. Then when the link is opened a 'Done' button will appear in the browser which will return you back to the application.
    Here is a link to the command and the available target values.

    I would recommend reviewing our sample-in-app-browser application for more information. If InAppBrowser does not work in your project, there could be some other javascript failing that would cause all js to fail. Isolating the issue in a sample is the best way to advise you accordingly.

    You've missed the Icenium Visual Studio Integration keynote? It has been recorded and posted here.
    Looking for tips & tricks directly from the Icenium team? Check out our blog!
    Share feedback and vote for features on our Feedback Portal.
  3. Markus
    Markus avatar
    205 posts
    Member since:
    Nov 2005

    Posted 10 Dec 2013 Link to this post

    Dear  Zdravko 

    It seems after redeploying it works now. Strange I refreshed the app on Android many times pressing the menu button.

    Well good thing it does now work.

Back to Top