This is a migrated thread and some comments may be shown as answers.

GridView dynamic columns not taking existing space

5 Answers 41 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Mark
Top achievements
Rank 1
Mark asked on 15 Mar 2011, 02:28 AM
testing the 2011 Q1 Beta to see performance gains on the grid, and noticed that when the grid is loaded it now takes the MinWidth value of the scroll viewer the root page itself has set (1200px), leaving a large blank space to the right of the columns
the grid however does not stretch the width of the grid it is part of

when the data is loaded and the dynamic columns are added they are added the end of the width and do not take the empty space
the grid stretches to the width of the grid and presents a horizontal scrollbar as needed

the blank space can be scrolled, but not minimized etc

can't see where to upload images to the thread
pre data load
http://i.imgur.com/SepK3.png

post data load
http://i.imgur.com/xHpCN.png

5 Answers, 1 is accepted

Sort by
0
Vlad
Telerik team
answered on 15 Mar 2011, 07:53 AM
Hello Liam,

Can you send us small runnable application where we can reproduce and debug this? You can open support ticket in order to attach the project. 

Greetings,
Vlad
the Telerik team
Registration for Q1 2011 What’s New Webinar Week is now open. Mark your calendar for the week starting March 21st and book your seat for a walk through all the exciting stuff we ship with the new release!
0
Mark
Top achievements
Rank 1
answered on 16 Mar 2011, 01:42 AM
0
Vlad
Telerik team
answered on 16 Mar 2011, 08:52 AM
Hello Liam,

 We can confirm this bug - you can track it here. I've added 2000 Telerik points to your account.

Kind regards,
Vlad
the Telerik team
Registration for Q1 2011 What’s New Webinar Week is now open. Mark your calendar for the week starting March 21st and book your seat for a walk through all the exciting stuff we ship with the new release!
0
Mark
Top achievements
Rank 1
answered on 22 Mar 2011, 06:30 AM
notice in PITS that this is set as resolved in Q3 2010 SP1, but the issue exists in 2011 Q1 release code

have also noticed that setting the columns to visible then invisible again fixes the issue as a work around
0
Vlad
Telerik team
answered on 22 Mar 2011, 08:30 AM
Hi Liam,

 We've noticed the version confusion as well and we will fix it today. 

Kind regards,
Vlad
the Telerik team
Tags
General Discussions
Asked by
Mark
Top achievements
Rank 1
Answers by
Vlad
Telerik team
Mark
Top achievements
Rank 1
Share this question
or