This is a migrated thread and some comments may be shown as answers.

Grid jumps up when <enter> is clicked

1 Answer 54 Views
Grid
This is a migrated thread and some comments may be shown as answers.
Salim
Top achievements
Rank 1
Salim asked on 13 Mar 2017, 12:37 PM

Check the following scenario:

1. Go to the following http://dojo.telerik.com/uwUno

2. Click on "Chai" (first cell)

3. Enter <enter> in keyboard. The grid jumps up.

How can we disable this?

1 Answer, 1 is accepted

Sort by
0
Alex Hajigeorgieva
Telerik team
answered on 15 Mar 2017, 08:57 AM
Hi Salim,

Unfortunately, this is the expected behaviour when the navigatable option of the Kendo UI Grid is set to true. The reason this happens is due to the table element getting focus and subsequently being scrolled into the browser's view. For more information, please check the forum post at:

http://www.telerik.com/forums/grid-selection---screen-jumps-scrolls#LVkMyRPUjU-uh5HvMF70Yw 

One way to handle this behaviour is to provide a height of the Kendo UI Grid which will fit in the browser's view:

http://dojo.telerik.com/ixOje

Kind Regards,
Alex Hajigeorgieva
Telerik by Progress
Try our brand new, jQuery-free Angular 2 components built from ground-up which deliver the business app essential building blocks - a grid component, data (charts) and form elements.
Tags
Grid
Asked by
Salim
Top achievements
Rank 1
Answers by
Alex Hajigeorgieva
Telerik team
Share this question
or